Why do TP-Link routers kick wireless users off and prompt for password?

I'm having the same problem with two different model TP-Link routers serving as access points.

The wireless will randomly kick users off and then endlessly prompt for the wi-fi password. Entering the correct password will not allow people to rejoin the network. But everything else is fine. The wired LAN ports still work, as well as traffic between the unit and main router. The only way to fix this is to power cycle the units, or to re-save the wireless settings in the configuration portal.

I'm about to kill someone and have exhausted all solutions found on this forum, including: changing the LAN IP address to a different subnet, using different wireless channels, and enabling IGMP proxy and snooping. The wi-fi network name is simply alphanumeric, as well as the password.

I can't be the only one experiencing this, but I can't find any other suggestions online. TP-Link's technical support, while present, has been fairly useless. Does anyone have an idea or a hunch of what's going on? How can I possibly be so unlucky?

Model 1: TL-WR1043ND v3, running LEDE 17.01.2
Model 2: Archer C50 v2, running TP-Link firmware build 160801

One thing is for sure; I shall never buy another TP-Link product again.

I've used a TP-Link Archer C7 v2 for a couple of years now, running stock, DD-WRT, OpenWRT, and now LEDE, with no issues.

I would start by checking the router logs.

Thank you for the input jwoods. Are you using your C7 as a router or access point? Do you think it could be an overheating issue caused by using 40 MHz bandwidth?

I went back to 20 MHz and so far it's been up for more than 24 hours, which is a little unusual.

Okay, with assistance from TP-Link support, it seems to be related to NAT. I've had it disabled since last Wednesday and the wireless has been working the whole time (using official TP-Link firmware). I'll keep monitoring.

I totally bought 6 TP-Link routers and 5 of them OPENWRT/LEDE compatible. Now I still have 2, one archer C7 v2 as main router and one WDR4300 as bridge relay.
Not saying TP-Link is very good, just because it has Atheros solution and nice price. I don't see any major issues. And Archer C7 is set to VHT80 (80MHz) on 5G and works very well.

I have a TL-WR1043ND v3 currently running LEDE 17.01.4, it ran 17.01.2 for months prior. I can not say I've encountered your problems. None of my wireless devices have ever randomly been booted and prompted to re-enter credentials to connect the wireless access point. Are you sure your /etc/config/wireless is set up properly on your router? It could also be your devices. Things like outdated or improperly configured drivers, malware, deauth attacks, etc., can cause issues. Can you tell me what type of devices you have, their OS, and type of wireless chip they have? I know that certain Broadcom chips have some issues on Linux, especially those that aren't officially supported by the kernel.

This is my current configuration for my TL-WR1043ND v3, 'xxxx' are redacted information.

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca955x_wmac'
	option htmode 'HT20'
	option country 'US'
	option frag '2347'
	option rts '2346'
	option txpower '25'
	option legacy_rates '0'
	option distance '200'
	option channel '6'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option short_preamble '1'
	option ssid 'xxxxxxxxxx'
	option encryption 'psk2+ccmp'
	option key 'xxxxxxxxxxxxxxxxxx'
	option maxassoc '8'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option wpa_disable_eapol_key_retries '1'
	option wmm '1'
	option bursting '1'
	option compression '1'
	option ff '1'
	option turbo '1'

Thank you for everyone's input. I will post the /etc/config/wireless when I'm back at the office and can power up the WR1043ND. It seems to make a difference if the unit is being used as an access point instead of a router. It sounds like you're running it as both a router and access point.

Our office uses iMacs and MacBooks dating from 2012 to now, and almost everyone has an iPhone (5s+). When the wireless crashes, no device can connect back to the network, even though it's still visible.

Earlier this week, the wireless crashed (Archer C50) with NAT and 5 GHz disabled. So I re-enabled 5 GHz and let TP-Link know. So far, so good. The WR1043ND doesn't even have 5 GHz, but the QCA9557 chipset supports it.

It's possible that I just happened to have two faulty units of different models that exhibit the same problem. The odds seem extremely low though.

Okay, Archer C50 v2 is a broken model altogether. It continually fails on the 2.4 GHz band, not the 5 GHz band. TP-Link sent me a brand new v2 as a replacement. It also failed the same way.

This was a terrible waste of time and I can't believe I went through all that troubleshooting. I guess I'm more patient than I should be. I will strongly advise people to avoid TP-Link. At the very least, you should avoid this model since the v2 is the only one being sold.

Apparently, Steven Zhang of TP-Link will be sending me replacement v3 units that contain a different chipset. I don't know if I will even bother setting them up.

As I mentioned above, I have been running TP-Link gear for almost 2 years now with no issue.

The fact that 2 different TP-Link router models had the same issue leads me to think it is not the router, or router firmware.

The only other explanation is some kind of EM interference in this office. Either way, it should NOT be failing like that. We had an Apple airport that worked flawlessly until it died after six years. I could likewise surmise that maybe all TP-Link routers would have the problem if positioned in the same spot. So while you haven't had issues, it doesn't mean there isn't a flaw in their products.

The reverse is also true...just because you are having issues, doesn't mean it's a TP-Link problem.

If it were me, I would start looking at wireless traffic in the area for channel saturation, and how you have the router configured.

If you are a Windows user, this is a nice free tool (requires email registration) for analyzing wireless traffic.


Some basics you can look for...iIf you are using "auto" for wireless channels, change it to either channel 1, 6, or 11 for 2.4 Ghz and if in the US, start with channel 153 for 5 Ghz.

Make sure WMM is checked.

Lots of good documentation here on the LEDE site.

Thanks. Every possible permutation in the wireless settings has been tried.

I don't think we ever saw your wireless, or network configs...

cat /etc/config/wireless

cat /etc/config/network

Make sure to obscure the "option key" value(s) in the wireless config results before posting.

Have you analyzed the wireless traffic in your immediate area?

The WR1043ND was no longer available for testing. Archer C50's are being used as access points.

Even if there were a million wi-fi networks, I don't see why I should expect the units to literally "drop-off" their 2.4 GHz bands after a while, when other routers have no problem.

This is a scan report in macOS.

23 PM

Incidentally, you can check out the reviews on Amazon here. If you sort by date, you can see how many people are loving this router.

I don't think you understand how wireless networking works...

Even if the C50 is a dog, that doesn't explain why the WR1043ND had the exact same problem.

Your macOS scan report tells you nothing about signal strength and signal quality, transmit and receive rates, etc. of your router.

I have the same problem.

config wifi-device 'radio0'option type 'mac80211'option channel '11'option hwmode '11g'option path 'platform/10300000.wmac'option htmode 'HT20'option disabled '0'option legacy_rates '1'option country 'BR'config wifi-iface 'default_radio0'option device 'radio0'option network 'lan'option mode 'ap'option ssid 'OpenWrt'option key 'forumw12'option disassoc_low_ack '0'option encryption 'psk2'

config wifi-ifaceoption network 'wwan'option ssid '3COM'option encryption 'psk2'option device 'radio0'option mode 'sta'option bssid '****'option key '11111111'option disassoc_low_ack '0'

Please reformat the config using the "code" button </> in the editor's toolbar so it's more readable


Which device, what release of OpenWrt, and exactly what problem? The OP was describing several devices and both OpenWrt and TP-Link firmware.

Edit: The config referenced below, now stuck out, is not that of the OP
BTW, It wouldn't surprise me if the OP's problems were from option maxassoc '8'

I was not the OP and never had problems. I just posted my config which works for me. I've had maxassoc '8' set for about a year now without issues. Although, my wireless config has changed a bit, it's still in there.

Are you running a Linux distro with a Broadcom wireless chip on your client? I also wouldn't recommend enabling legacy rates. If you are running Linux distro on your client I would recommend disabling any power savings for wireless devices controlled by NetworkManager.