Why am I having trouble signing in/signing up to the forums?

I try to sign in. Tells me I have the wrong password. So I click a password reset link. You tell me I don't have an account. So I try to create an account and you tell me there's already an account on that email. Only then does the link you sent me to reset the password work.

Not very encouraging.

I'm here because after using tomato for many years I have a device which runs openwrt but not tomato. And to create static routes, I can do it from the command line but impossible to do it from the web interface. I create static routes, but the command line never knows about them. The documentation wants me to spend a week to get the answer to the question. It's far cheaper to give away the device to somebody who's already spent a long time figuring out your completely unintuitive system.

Sounds like a plan ...

5 Likes
  1. Nobody forced you to install OpenWrt
  2. You can easily contribute and improve this "completely unintuitive system"
6 Likes

I don't smoke. Did you have any other questions?

9 Likes

Sorry you had some trouble getting into these forums. Did you create a new account recently? And did you get the confirmation email to activate the account and then follow the link for that? We can look to see what might be going with the account (we can do this via PMs if you'd like).

It is possible to create static routes via LuCI... no issues whatsoever in my testing. Maybe there is some other factor... let's try to figure it out.

let's start here: what is the output of

ubus call system board
4 Likes

Looks like OpenWrt is not suited to your needs, perhaps you should try something else.

2 Likes

OP's been a member nearly 3 years, but just posted today - to complain?

I thought maybe they wanted a link to the Static Routes wiki page, but I don't see anywhere on that page that you must spend a week to get the answer. They must be on the wrong website.

screen501

1 Like

I don't know if this helps (I put the device away, didn't know people would respond like that), I then put a line in the startup script adding a static route. No static route after restart. Copied the line from the startup script into a putty session and it created the route. I"ll go plug it in again and run the command.

The details of the implementation in the startup script would also be useful... but typically you simply add a static route to the /etc/config/network file once (using LuCI, UCI commands, or direct editing of the config file) and then never touch it again, so a startup script doesn't seem like the right place to put a static route.

"kernel": "5.10.161",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "Netgear R6220",
"board_name": "netgear,r6220",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "22.03.3",
"revision": "r20028-43d71ad93e",
"target": "ramips/mt7621",
"description": "OpenWrt 22.03.3 r20028-43d71ad93e"

ok... so you might want to consider upgrading to 22.03.5, but other than that, this should be fine.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network

and while I couldn't change my password, I wanted to try to create a new account, but couldn't find a "register" link anywhere.

perhaps somebody can explain why the gui would accept numerous static routes and then ip route command would show no routes beyond the default route?

Back in January 2021, there was a security issue and, out of an abundance of caution, all accounts were required to change their password. I wonder if this is why you couldn't get in.

I'd have to see your config file and the resulting output of route

1 Like

Put your custom commands here that should be executed once

the system init finished. By default this file does nothing.

ip route add 192.168.24.0/24 dev br-lan via 192.168.20.58
exit 0


OpenWrt 22.03.3, r20028-43d71ad93e

root@OpenWrt:~# ip route
192.168.20.0/24 dev br-lan scope link src 192.168.20.1
root@OpenWrt:~#

if I copy the line from the script at the command line, I get the route I want.

I was encouraged by reading your propaganda that it's a substitute good for tomato. The r6220 was much cheaper than a tomato compatible device. So, no, nobody made me, but somebody wrote some things which I'm trying to confirm if they were true. Tomato gives me the same results for static routes in the gui and on the command line. I can put a startup script in tomato and it will actually do what's written in the script.


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd7f:7c41:b37a::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.20.1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config route
        option target '192.168.68.0/22'
        option gateway '192.168.50.68'
        option type 'anycast'
        option interface 'lan'
        option table 'main'
        option source '192.168.50.150'

ok.  I see my static route there, but it didn't function.  why wouldn't it be in the output of "ip route"?  Probably the same reason it didn't function.

and I still can't sign into the forum on another machine using the password I just created. it tells me the password is wrong, and then if I try to change it, it still tells me that there's no account using the email I've used to be here. And still no sign of a register link to create another account that might not have these problems.

why are you trying to add the route this way? It is not persistent. Instead, you can use the static route options in the config file:

Try removing the anycast line -- by default, it will be unicast which is what you probably want/need. Also remove the table since you only have a single table.
Also, do you only want this static route to apply to the host at 192.168.50.150?

config route
        option target '192.168.68.0/22'
        option gateway '192.168.50.68'
        option interface 'lan'
        option source '192.168.50.150'

I only tried anycast because unicast didn't work. I want the route to apply to every device which has that machine as its gateway. I have a bunch of static routes to put but once I saw that it didn't behave as expected I only tried with one. So I still don't see why the route wouldn't work, why it wouldn't show up in the ip route command.