White noise on shairport

i have installed shairport-sync on my Linkit-7688, version 2.6-openssl-Avahi-ALSA-soxr.
I can stream music with success, but sometimes i hear a strange noise in background.
It appear in both channels in random moments. I have searched a lot around the net.
The only thing i have found is this file /etc/asound.conf :

# This is a simple configuration that will disable DMIX for ALSA, useful for configurations that uses USB speakers.
# Most USB sound card / speakers doesn't have a mixer, so ALSA will default to DMIX which has a poor quality.
# Disabling it will direct PCM to speaker without going through DMIX
# Uncomment if you hear noises using ShairPort in WRT with USB speakers.

 type plug
 slave.pcm hw

i have tried to use this asound.conf for my board but now i can't hear the music at all.
Can someone help me to get rid of this annoying noise?

Are you absolutely sure that your device's DAC does not introduce noticeable noises while playing sounds directly (eg. playing some files)?

Yes I'm sure,
this behavior only happens only when the work-load of the processor is higher than usual. otherwise it works fine for hours.
So i really thinks DAC is not a problem.
I have to say tho that the work-load is higher when the board have to handle others (differents) networks requests. So i can't really tell if the problem is processor wise or network wise.
I hope this can clarify my issue.

1 Like

Have you tried using external DAC (USB for example)? I think the built-in one may pick up interferences from other stuff on the board (that's why there's more noise when CPU has higher load on it).

By the way if you're going to connect USB DAC then try using additional filter like Audioquest JitterBug, this tiny thing makes absolute wonders when it comes to sound quality improvement.

For me this looks like a bad physical grounding. If the power supply doesn't have physical grounding, maybe it's not correctly isolated from the mains.

You can try to add a ferrite bead to the USB cable.

Hi everyone,
we are still stucked on this weird problem.
We got two differents board: Carambola2 of 8devices and Linkit smart 7688.
One (Linkit) got this problem of this weird noise that appear pretty randomly. The Carambola doesn't.
We have got all the same config files for alsa and shairport. So we got stucked to search the reason of the problem of the Linkit for weeks.
Today i found something. If i connect with ssh in both boards when listening to shairport service and i manage to write a huge file in both boards, the Linkit trigger the noise. The carambola won't.
Linkit goes in this state at the first writing of the file. The Carambola no matter how much i write, always reproduce the audio correctly.
This is weird becouse Linkit got even better specs in terms of processor and memory.
How can i resolve this on my Linkit?
Thanks a lot

does the noise persist if;

  • you write to /tmp/BIGFILE?
  • you write from a 2GHz vs 5Ghz client ( assuming it has both )

Assuming it's not a mixer issue... it's likely generic to the device... so you'll likely get much more info if you run a broad websearch on the issue... odds are it's happened to others... but you may be unlucky and have a less common component issue so you'll have to break out the multimeter or receipt to resolve... ( option A is do-able but not easy so again... maybe hit up the link-it or related electronics forum for assistance )...

I just tested to write on /tmp and the problem wont be triggered.
So im assuming that some process is writing a lot on system folders and that create the issue?
Should i redirect the output on /tmp?
How can i discover what process is creating this issue?