Which correct HLK-7688A firmware?

Hi All!

I bought HLK-7688A module and which I use OpenWRT firmware!? The Linkit Smart 7688 firmware don't work. :frowning:
Thank you!


For reference https://openwrt.org/toh/seeed/linkit7688

The link from that page shows a complete eval board, not the bare module shown at your link.

From your link to the specific module you purchased

Note: This product is only including one 7688A module and our default version is openwrt version,if you need the test board or the transparent version with our software,please make notes ,or contact with us:
Email;sunny@hlktech.cn ,skype:hlktech

When you say "don't work", what is not working? What specific firmware have you tried? How did you try to install it?

I turned power on module, and nothing, continously reboot, and I don't connect in false mode from PC in WAN port (LAN port nothing, 10Mb/s requirement change).
I prefer this OpenWRT firmware, and I tried uploaded with TFTP server, but say UART: "ARP Required ; Bad Checksum error".
The next solution I uploaded firmware with "Kermit mode" but that neither good idea, because say: "Bad Magic Number,FFFFFFFF".
What do I do wrong? What is the good solution?
Thank you!

Proof that 15.x works with that model ( via web or usb ).....

a) have you spoken to the vendor yet?
b) what version are you using?
c) why have you not tried USB yet if it is recommended on ALL the device materials?

To repeat what Jeff already mentioned:

with our firmware,if you need the openwrt version to make your own software,please contact with us

I have written the vendor but nothing response. :frowning:
The bootloader section fine, but don't boot OpenWRT 18.06.02.
The previous OpenWRT 15.x forever continously restart (2-3x) and power off.
I tried TFTP (ARP Required ; Bad Checksum error) and Kermit mode( Bad Magic Number,FFFFFFFF), but don't work.
Does this work for anyone?
Thank you!

Up guys,

Do you have some answer for the probleme of @drcyberg ?
I'm currently in the same situation, after trying to upgrade firmware by the kermit methode (with OpenWRT 18.06.02) the Hi-link HLK-7688A continously reboot (3 time) and stop.

When i suceceed to connect by the web interface with the wi-fi (for a short time before the rebooting) the firmeware version is always 14.xx barrier breaker.

thanks by advance for yours lights


This Hi-Link variant needs to be tested by someone who has the requisite skills.

If you get UART there is a chance someone may assist.... otherwise contact the vendor and let all of us know what is going on, or get the seedstudio, which is supported.

Post a full UART bootlog on system with issues here in code tags, or buy one and send to a developer.... :wink:

1 Like

I also bought a board from this vendor, the hardware is okay but the software is not at all.

I had to flash a new u-boot via jtag to get TFTP working correctly. No problem now.

Careful before you tell curse, see this post:

The HLK-7628AN target in openwrt-19.07 is working okay.

1 Like