Where to find kernel defconfig official builds

hi, i cant find the defconfig anywhere. the official builds from both x-wrt and openwrt dont use defconfig export in ./proc/config.
im concerned in getting both official defconfigs used for openwrt but more so for x-wrt.

if anyone has any clue please let me know.

thanks

kmod-ikconfig

1 Like

Isn't this the "config.buildinfo" file included in each release target/profile?
e.g.
https://downloads.openwrt.org/releases/19.07.2/targets/mvebu/cortexa9/config.buildinfo

No.
That is the OpenWrt config, not the low-level kernel config.

2 Likes

The kernel defconfig is a bit fluid in the OpenWrt context. It has several layers.

On bottom there are the built-in Linux defaults in Linux sources, then the generic config from target/linux/generic, then the target and subtarget config a from e.g. target/linux/ipq806x.

Those get combined to the final kernel config during the build, and that final config can be found from the kernel build directories after the build process.

(No idea about x-wrt that you mentioned.)

Is the disk cost so expensive that the kernel config has to be excluded by default? Having to dig into the source code, through those layers, is rather cumbersome.

Cost? Expensive?
You have to think as size, not as traditional cost.

In the old days, most routers had 4 MB or the luxurious 8 MB of flash memory, and you had a real shortage of storage bytes. Lately there are routers with 128 MB or more flash, but still the thinking in OpenWrt starts from the "for resource-constrained devices" angle.

That is where it starts but does it end there as well? Or should/could targets not be more diverse instead of penalizing more capable devices? (one example recent fpu compiler setting for mvebu target putting ARM 370 on par with ARM 385).

i really need it as im experimenting with the mir3 and cannot trace it. the mir3 only boots with a certain config unlike compatible routers. its rockstable on x-wrt and want to use that to build modded openwrt with it. i havent checked too much other than proc/config.gz maybe it can be extracted from the binaries? maybe the maintainers of it are interested to share?

somehow overlooked this message. will update as soon as i try

It was mentioned here

A bit cumbersome to go about

download (if that is the correct target) https://downloads.openwrt.org/releases/19.07.2/targets/ramips/mt7620/openwrt-imagebuilder-19.07.2-ramips-mt7620.Linux-x86_64.tar.xz

then look for .config file in openwrt-imagebuilder-19.07.2-ramips-mt7620.Linux-x86_64

it worked did opkg update and force install kmod-ikconfig the file was on /proc/config.gz of router within config.gz extracted defconfig from it and there it is. thanks so much. marking this topic as solved.

i extracted the config btw for mir3 and miwifi both xiaomi same chip.
it was exactly same in diff, i guess it has to be regenerated after router selection if there would be any significant change in config to be seen.

after further trying unfortunately afaik this defconfig is a general stock defconfig which is extracted and well regenerating it upon device does make it a device specific one.

but this was the issue i had building from the stockdefconfig of the source itself as well. it didnt work out so well. can anyone confirm there are more changes to the actual defconfig on kernel level the buildbot uses as compared to this stock source generated one?

for example it regenerates with testing_kernel=y which is the 5.4 kernel while the buildbot images are 4.14. am a bit confused. have included an image of the regenerated menuconfig, is this the only thing needed? theres more to it right? id be glad if anyone can confirm.1

found the answer on wiki:

  • Select all target specific packages by default

  • Select all kernel module packages by default

  • Select all userspace packages by default

guess just regenerating and this above. for x-wrt the buildbot packages too. topic solved.

actually my bad this above had to be disabled completely. only if i manually configure the defconfig i can get it to boot and work but there are still differences from official builds of openwrt/x-wrt. since the original defconfig isnt provied there is still no answer as to solving this topic unfortunately.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.