Where is cloudflared package?

Cloudflared tunnel disappeared from packages dir for 23.05. What happened?

1 Like

Fails to compile...
Due to Go version incompatibility.

../../vendor/github.com/quic-go/quic-go/internal/qtls/go121.go:5:13: cannot use "The version of quic-go you're using can't be built on Go 1.21 yet. For more details, please see https://github.com/quic-go/quic-go/wiki/quic-go-and-Go-versions." (untyped string constant "The version of quic-go you're using can't be built on Go 1.21 yet. F...) as int value in variable declaration

3 Likes

Yep. Had to update the Makefile to get dnscrypt-proxy2 (now updated) to get it to build on my last update. Kinda wonder why other the packages relying on current Go version where not updated?

1 Like

Cloudflared still exists as ipk in 22.03 packages repo. I wonder if it can be used directly for 23.05....

If you don’t build your own, best wait until it gets fixed. (dnscrypt-proxy2 was updated to new Go version about 7 days later)

any updates here, especially regarding release 23.05.2?

No. Still showing in faillogs today. Seems to be an upstream issue.

See issue #22383