Where is 18.06.3?

Last night I updated my Linksys WRT3200ACM with OpenWRT 18.06.3. Everything is OK. Today I run opkg update and I see errors: no reachable address. Check on the OpenWRT page and see that the folder with version 18.06.3 has disappeared. Where have you been?

1 Like

You are jumping the gun a bit, 18.06.3 is not officially released yet.


The 18.06.3 folder was here: https://downloads.openwrt.org/releases/ And it was there for about a week. How do I understand when it's official?

1 Like

When it is announced as released and linked from the front page. The 18.06.3 directory wasn't even built completely, and now the buildbots are taking a second swing at it. But in a way you are right, previously the directories undergoing building were hidden from sight.


Totally with you on this. I was about to update my WRT1900AC V1 last night to 18.06.3 as I saw it in that directory but was confused why it wasn't listened on the main page. Waited until today and now it's gone, but not only that, the original 18.06.2 was removed and then reuploaded as seen by the new date.

That is also the signal for me to update the ToH dataentries accordingly.

1 Like

In the process of fixing build issues, 18.06.2 was accidentally rebuilt instead of 18.06.3. Misterks happen, most of us are only human.


Now I have updated with sysupgrade from cli. How should I behave?

Very politely, of course :wink:

If you’re functional, sit tight and wait for the official release, then reflash.

If you’re not functional, let us know what’s missing and folks here can offer some guidance based on the current state of things.


Everything works perfectly. I will sit and wait for the official release. Thanks to the availability.

like so?



Would you happen to know if the rebuilt 18.06.2 build would still be labeled as 18.06.3? Wondering because I flashed mine and it's labeled as 18.06.3. Not a big deal as I was planning on reflashing when the builds were complete, just curious.

Labeled where? In the system itself? I honestly have no idea, I didn't flash an 18.06.2 build in the last few days,.

1 Like

Thanks, just misunderstood your original comment.

You can always cross-reference the kernel version with the release notes for the respective version of OpenWRT.


Can't believe I didn't think of that, 18.06.3 isn't up anymore, but the kernel on the build I installed is 4.14.128 and 18.06.2 is 4.14.95, so at least it doesn't appear to be 18.06.2.

Just yesterday, I changed my router for my company.
I found openwrt 18.06.3,
so I downloaded it. Now the router has become our company's main route and is in use.

But now the problem arises.
I'm going to install zerotier for it, but I found that opkg update returned an error.
When I checked the erroneous urls, I found that they returned 404.
So I browsed downloads.openwrt.org again.
I found 18.06.3 disappeared.
I tried to use the 18.06.2 software repository, but the installation prompted the kernel signature error.
Then I plan to use SDK to compile ipk.
But I found that I didn't download the corresponding version of SDK at all.

What should I do now?

What do you think of downgrading to 18.06.2?

Also I wouldn't upgrade your company's productive main router to a new firmware nearly no one has tested in production.


I also think this is the best way to do it.

However, the router has been put into use, and it currently links 40 devices.
So reinstallation will stop most people in the company for a while.

I would like to try not to change firmware if I can.
What other methods are recommended?