I'm wondering where I can find the current documentation about Network configuration for DSA Switch/Bridge configuration options?
What can be used on config device
when option type bridge
is used?
What can be used on config bridge-vlan
?
Is this section https://openwrt.org/docs/guide-user/network/network_configuration#bridge_options still up to date (in regard when a single vlan aware bridge is used)?
3 Likes
At least in the meantime I got to know that you can set macaddr
within an interface
stanza. (I, wrongfully, thought it could only be set on device
.)
Example snippet from OpenWrt 23.05.5 on x86:
...
config device
option name 'br-vlan'
option type 'bridge'
list ports 'eth0'
option macaddr '02:00:01:01:00:01'
# VLAN 16/0x10
config bridge-vlan
option device 'br-vlan'
option vlan '16'
list ports 'eth0:t'
config interface 'vlan16'
option device 'br-vlan.16'
option macaddr '02:00:01:01:00:10'
option proto 'static'
option ipaddr '192.168.16.1/24'
list ip6ifaceid '::1'
list ip6ifaceid 'eui64'
option ip6assign '64'
option ip6hint '10'
# VLAN 17/0x11
config bridge-vlan
option device 'br-vlan'
option vlan '17'
list ports 'eth0:t'
config interface 'vlan17'
option device 'br-vlan.17'
option macaddr '02:00:01:01:00:11'
option proto 'static'
option ipaddr '192.168.17.1/24'
list ip6ifaceid '::1'
list ip6ifaceid 'eui64'
option ip6assign '64'
option ip6hint '11'
...
# ip -br link
...
eth0 UP 20:7c:14:a2:b0:84 <BROADCAST,MULTICAST,UP,LOWER_UP>
br-vlan UP 02:00:01:01:00:01 <BROADCAST,MULTICAST,UP,LOWER_UP>
br-vlan.16@br-vlan UP 02:00:01:01:00:10 <BROADCAST,MULTICAST,UP,LOWER_UP>
br-vlan.17@br-vlan UP 02:00:01:01:00:11 <BROADCAST,MULTICAST,UP,LOWER_UP>
...
# bridge vlan
port vlan-id
eth0 16
17
br-vlan 16
17
...
https://openwrt.org/docs/guide-user/network/dsa/start
(First web search result for 'DSA OpenWrt')
You are kidding, right?
I'm looking for a list of UCI settings, like this one https://openwrt.org/docs/guide-user/base-system/dhcp
Not kidding.
There are networking examples found there. I literally assisted a noob - he configured his device (by himself) using the Wiki.
No. I just want a list of all available options for bridge-vlan
and device
IF a VLAN-aware bridge is used.
1 Like