Where are Edgerouter X install files?

https://openwrt.org/toh/hwdata/ubiquiti/ubiquiti_edgerouter_x
has no "Firmware OpenWrt Install URL" line. Is
openwrt-23.05.0-ramips-mt7621-ubnt_edgerouter-x-initramfs-kernel.bin
it?

The installation method is described in the device info page.

And you can find the latest files using the firmware selector

I scp'd openwrt-ramips-mt7621-ubnt_edgerouter-x-initramfs-factory.tar to the Edgerouter:

ubnt@ubnt:~$ ls -l /tmp/open*
-rw-r--r--    1 ubnt     users      3010560 Dec 31 22:44 /tmp/openwrt-ramips-mt7621-ubnt_edgerouter-x-initramfs-factory.tar

However:

ubnt@ubnt:/$ add system image /tmp/openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar
Cannot find upgrade image. Upgrade failed.

I'm not sure why that would happen. What happens if you chmod 777 that file and then try to run the upgrade?

Chmod 777 didn't help.

Using the system tab in the Web interface did and I was able to log in
via ssh as root@OpenWrt.

scp from my desktop to the Edgerouter failed:

toncho/~/edgerouter 14 scp openwrt-ramips-mt7621-ubnt_edgerouter-x-squashfs-sysupgrade.bin root@192.168.1.1:/tmp/
ash: /usr/libexec/sftp-server: not found
scp: Connection closed

scp in the other direction worked:

root@OpenWrt:~# sysupgrade -n /tmp/openwrt-ramips-mt7621-ubnt_edgerouter-x-squashfs-sysupgrade.bin
Sun Nov 13 17:45:08 UTC 2022 upgrade: Commencing upgrade. Closing all shell sessions.
Command failed: Connection failed
root@OpenWrt:~# Connection to 192.168.1.1 closed by remote host.
Connection to 192.168.1.1 closed.

Gave it half an hour. No ping, can't connect via http or ssh on any port. The light on any port I plug a cable into comes on and blinks twice every ten seconds. Power cycling makes no difference.

What version of EdgeMax were you running prior to installing OpenWrt?

If it was >=v2.0, the bootloader should be newer (hopefully) and there is a debricking method you can use with tftp. If not, you may need to break out a serial UART adapter.

https://openwrt.org/toh/ubiquiti/edgerouter_x_er-x_ka#debricking

What version of EdgeMax were you running prior to installing OpenWrt?

2.0.6

I will try the serial method as soon as I scare up an adapter.

I was able to re-install EdgeOS by the tftp method after I realized that tftp needs the "binary" command. From there everything worked as expected and I now have OpenWrt installed. Thank you.

great!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.