When power is lost; DNS resolution is lost on Linksys EA8300 ( OpenWrt 19.07.3) and router settings must be reset

We've been having some power outages. I noticed that when the power is lost unexpectedly to the router we lose DNS resolution. The only way I've been able to resolve it is to reset the router settings and restore from a backup. Very annoying. Happy to paste any config settings that you folks would like to see.

Many thanks in advance.

Examples after the reboot

root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/releases/19.07.3/targets/ipq40xx/generic/packages/Packages.gz
Failed to establish connection
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.3/targets/ipq40xx/generic/packages/Packages.gz

...
root@OpenWrt:~#  cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd44:0eb4:a73c::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

........

root@OpenWrt:~# ping google.com
ping: bad address 'google.com'
root@OpenWrt:~# ping google.com
ping: bad address 'google.com'
root@OpenWrt:~#
root@OpenWrt:~# /etc/init.d/dnsmasq start
udhcpc: started, v1.30.1
udhcpc: sending discover
udhcpc: no lease, failing
root@OpenWrt:~# /etc/init.d/dnsmasq enable
root@OpenWrt:~# ping google.com
ping: bad address 'google.com'
root@OpenWrt:~# ping www.google.com
ping: bad address 'www.google.com'
root@OpenWrt:~# ping www.google.com
^[[Aping: bad address 'www.google.com'
root@OpenWrt:~# ping www.google.com^C
root@OpenWrt:~# ping www.google.com
ping: bad address 'www.google.com'
root@OpenWrt:~# cat /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 208.67.220.220
nameserver 208.67.222.222
nameserver 10.200.0.1
nameserver 127.0.0.53
nameserver 127.0.0.1
search lan

...... 

# tried to delete /etc/resolv.conf and give it google dns instead but i really confess i have no idea what's going on lol.
# setup goes like ISP (cable internet) => surfboard 6183 => linksys router

Are you able to ping the DNS servers by their actual IP addresses when DNS apparently fails?

2 Likes

So you're saying:

ping 8.8.8.8

and not ping google.com?

yes, ping actual IP address to confirm connectivity exists.

1 Like