What is the latest adapted version of openwrt for the TL-WR1043ND router?

I have a TL-WR1043ND router with Backfire 10.03 installed on it.
Can I upgrade this version to a newer one? and how to do it?

Depends on the version of your device, check https://firmware-selector.openwrt.org/

1 Like

I have TP-Link TL-WR1043N/ND v1, there is no such option.

Then it's not supported.

what is the latest version supported?

Is this your device?

If so, the v1 has only 32mb of ram, and while it can theoretically run 22.03, you may experience out of memory crashes due to the limited ram.

2 Likes

Hi.
I have used this device a few montsh ago. I installed 21.02 with no wifi, with the aim of a simple manageable switch.

Thanks everyone, I installed 23.03.5. Everything worked, although I had to reset all the settings.

I second that - out-of-memory crashes do occur on that device even with 21.02 configured as an access point. You might want to stop uhttpd once you configure the router. If you plan to use it as an access point, you can also disable dnsmasq, firewall and odhcpd.

Agreed. That is what I have done + no wifi driver.

1 Like