What is default / right way to setup dual band wifi router so clients will switch wifi bands as needed?

Hi!
Assuming I have more or less modern dual-band OpenWrt router (like Netgear WAC104), what is proper way to configure its wifi, so moving clients can pick/switch radio band depending of noise/quality/congestion ?

Should I use same or different SSIDs on both bands? With same passwords?

Can/should I enable 802.11v? I do not see any option for that?

Should I use Fast Transitions (802.11r) for that? Seems it's more suitable for muliti AP setups.

Ideally I would like to provide to clients one SSID + password and have client automagically pick and switch bands without breaking any connections.

1 Like

802.11r works, I haven't tried it between bands, but I think someone replied it did.

I'd set up two identical SSIDs, with 802.11r.

1 Like

That’s right, just replicate the 802.11r config for both bands. Works very well here.

2 Likes

I'd be also interested in this in a little bit more detail. I've just purchased a linksys mr8300 which has 3 bands and I'm not sure what is the best configuration. (btw, this is my first time installing, setting up openwrt)

How does openwrt work when assigning the same SSIDs to all of the bands? I assume the original firmware does something "special" in order to get the advantages of this and not just "randomly" changing channels for clients (I've read something similar here in the forum although I think it was from 2018). Question is if openwrt is smart enough as well with the default settings or do I need to tweak it somehow for this specific 3 band case?

If there is a good guide/doc regarding this please link it, I couldn't really find any relevant information other than a few forum posts which did not really convince me that just setting up the same SSIDs will work properly. Sorry if I missed something!

Thanks!

Setting the individual bands works. Here is my example (802.1x):

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option encryption 'wpa2'
        option auth_server <redacted, not needed for non 802.1x>
        option auth_port <redacted, not needed for non 802.1x>
        option auth_secret <redacted, not needed for non 802.1x>
        option ieee80211r '1'
        option dynamic_vlan '2'
        option vlan_tagged_interface 'eth0'
        option vlan_bridge 'br-vlan'
        option vlan_naming '0'
        option mobility_domain <redacted, not needed for non 802.1x>
        option ft_over_ds '0'
        option ft_psk_generate_local '0'
        option nasid <redacted, not needed for non 802.1x>
        option r1_key_holder <redacted, not needed for non 802.1x>
        list r0kh <redacted, not needed for non 802.1x>
        list r1kh <redacted, not needed for non 802.1x>
        option reassociation_deadline '20000'
        option ssid <redacted>
        option dtim_period '5'
        option wpa_group_rekey '72000'
        option max_inactivity '15'
        option network <redacted>
        option rsn_preauth '1'


config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option encryption 'wpa2'
        option auth_server <redacted, not needed for non 802.1x>
        option auth_port <redacted, not needed for non 802.1x>
        option auth_secret <redacted, not needed for non 802.1x>
        option dynamic_vlan '2'
        option vlan_tagged_interface 'eth0'
        option vlan_bridge 'br-vlan'
        option vlan_naming '0'
        option ieee80211r '1'
        option mobility_domain <redacted, not needed for non 802.1x>
        option ft_over_ds '0'
        option ft_psk_generate_local '0'
        option nasid <redacted, not needed for non 802.1x>
        option r1_key_holder <redacted, not needed for non 802.1x>
        list r0kh <redacted, not needed for non 802.1x>
        list r1kh <redacted, not needed for non 802.1x>
        option reassociation_deadline '20000'
        option ssid <redacted>
        option dtim_period '5'
        option wpa_group_rekey '72000'
        option max_inactivity '15'
        option network <redacted>
        option rsn_preauth '1'

Note that this also has dynamic VLAN set up (through RADIUS). The DTIM values is for iphones. If you do not create your own r0kh and r1kh, you'll want to set ft_psk_generate_local to '1'

I found this very simple way as the "right" way for my home network. Had plans to setup 802.11r and others, but have never got to it, maybe will one day. Until now blogist Anarcat offered fine tip to lower txpower on 2.4GHz ja raise txpower on 5GHz.

https://anarc.at/blog/2022-04-13-wifi-tuning/

Before this I had both 2.4 and 5 GHz with same SSID. It seemed that wifi STA behaviour was more stochastic than now. This is all I have for backing up the "right way" here.

Now family members having their bedrooms farther away and more attenuation to AP are more happier, at least their vocal complains and grumblings are lacking. For requests if they were using phone tethering and/or mobile networks more, they denied and said to use home wifi.

Well thanks for both of the replies, but I'll be honest, I don't think you really answered my question(s). Thanks for trying to help though!
I guess I'll have to look at the code some time in the future to properly understand what is "happening" exactly and if the setup mentioned at the beginning of this topic is indeed correct.