What configuration is required for NetBIOS to work with OpenWrt?

I have been having random issues with the wireless on my Linksys WRT3200ACM as a result of recent DD-WRT updates, even after clearing all configuration data and starting fresh. These issues have been causing clients to disconnect randomly or be unable to connect entirely. As an experiment, I tried flashing OpenWrt today to see if this made any improvement and so far wireless has worked flawlessly.

I have a CentOS server on the wired network with a WINS and Samba share which is visible to Windows machines via a NetBIOS name. I have used this configuration on my router with DD-WRT for several years. Samba is configured correctly and NetBIOS has continued to work without issue through past DD-WRT updates and complete setting wipes on the router.

However, flashing the server to OpenWrt caused NetBIOS to fail to resolve hostnames. I could still connect to Samba shared by IP \\ but I could not connect via \\name.

I tried rebooting the router and even installed Samba on the router to see if it could act as a WINS server but nothing seemed to work. I tried following this guide for advice on which packages and configuration options:

ROOter/OpenWRT Samba Cross-Platform Setup with a WINS Server - LTE HACKS

Installing these packages did not solve the problem so I uninstalled these packages from OpenWrt and rebooted. Then at some point while doing nothing NetBIOS names started to resolve. I can now access my network shares via \\name\share as normal.

I don't know what I did. My only guess is that by uninstalling Samba and its dependencies I also inadvertently uninstalled some other package which was causing a problem.

Is there some default configuration or package that conflicts with NetBIOS? I would like to understand what the problem was for the future in case I encounter this again.

I haven't changed anything with the router settings and NetBIOS names have stopped working.

NetBIOS/ WINS is severely deprecated, to the extent that neither modern samba nor contemporary windows versions use it. Name resolution usually happens via (local-) DNS, ideally by defining static DHCP leases (with option dns '1') - automatically assigned DHCP leases are also added to the list (internal state) and tend to resolve (after the next DHCP renewal), but this is less reliable.


Network address names have disappeared again despite having touched nothing. Trying to access a server by its name does not connect but the IP address works fine.

What can I do to make them come back again?

not sure why you are using netbios, this is just a static dhcp/DNS resolution.
set a static DHCP lease https://openwrt.org/docs/guide-user/base-system/dhcp#static_leases (can be done with web interface too to map to whatever the samba server hostname is and check what is the domain name set on the OpenWrt router (default should be .lan)

Then you can just connect with \\myserver.lan

this should also work in DD-WRT


What does NetBIOS have to do with the router?

The router isn't Windows - you acknowledge so yourself.

Are you issuing the WINS and NetBIOS servers via DHCP or something (which is possible)?

Wait...then what was your WINS server before; and why did you install conflicting WINS servers (which even the Samba manual warns against)???

If it's really NetBIOS:

  • Likely, fix the firewall on your NetBIOS server/clients
  • Verify you see the hosts broadcasting their names via NetBIOS protocol using Wireshark

Did you have anything else installed for this to work before Samba?

(TBH, you're the first person I've met in years trying to still run NetBIOS...hummm...)

I honestly think this is the issue.

:bulb: My theory is one of these:

  • the "NetBIOS" names matched the Interent/DNS names...and perhaps at some point, the OP's search domain changed, hence breaking [DNS] resolution - believed to be NetBIOS but wasn't; or
  • some other disabling of DNS (which was truly providing the hostnames)
  • The OP has install multiple WINS servers on the same network
  • The WINS server is firewalled

BTW if it matters for the OP - NetBIOS does not work on IPv6, they simply didn't migrate it over.