Western Digital My Net N600 read-only error

I tried to flash the firmware on my WD My Net N600 through the OEM GUI but got an "upload failed" message. When I tried again at the command line, the error message was "read-only file system". After some checking, I found that every directory is read-only and the chattr command is not available. Any ideas?

Which one exactly?

Which installation instructions are you following?

2 Likes

I tried options 1 & 2. Option 1 gave me the "failed" message, while option 2 gave "read-only" error when I tried downloading the file. I was able to resolve the issue by creating a new user account; the account's home directory was read/write so I was able to download & install successfully.

The instructions say to use the OEM's emergency flash web GUI, that is ran by booting holding the reset button. Glad you worked through your issues.

I'm curious, did you read the install instructions prior to flashing?

???

Odd...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.