Western Digital My Book Live upgrade from 18 to 19

Hi, I want to upgrade my Western Digital My Book Live Single box from 18.06.2 (ext4) to 19.07.4

Should I upgrade to ext4 or squashfs? which one is better and what are the known benefits?
I just use it for minidlna and samba share, and have hd-idle to spin-off to save power when not in use.

There is a way to preserve current configuration? (at lest the dhcp/ip, I have in an difficult to access place currently)

I am reading https://openwrt.org/toh/wd/mybooklive#upgrading

but when I ran sysupgrade command I receive an error:

root@WDMybookLive:/tmp# sysupgrade -v -c /tmp/openwrt-19.07.4-apm821xx-sata-wd_mybooklive-ext4-sysupgrade.img.gz
Cannot find '/overlay/upper/etc', required for '-c'

do anyone knows how must I proceed?

LOL, anxious me,
Just uploaded https://downloads.openwrt.org/releases/19.07.4/targets/apm821xx/sata/openwrt-19.07.4-apm821xx-sata-wd_mybooklive-squashfs-sysupgrade.img.gz into http://192.168.1.x/cgi-bin/luci/admin/system/flash and it worked and basic configuration was preserved.

I don't have a fully formed opinion on squashfs vs. ext4. I personally started out with ext4 images, and I will continue to use ext4 images, because why not. As far as I know, squashfs' primary benefit is the compressed rootfs, which is obviously useful for space-constrained devices. Also you can reset a device to a "virgin" rootfs by simply clearing the overlay file system. But honestly, I don't think one has the benefit over the other with an MBL.

However, what I do is build my own images (using imagebuilder) for MBL that include a basic DHCP network config, samba, and some file system tools like fdisk, gdisk, and e2fsprogs. Not because there is an immediate need to do so, but because it's really handy to not have to re-install these packages after upgrading.

can you share please your script to build your image? that will be handy,
I am currenly doing this:

# ----------------------------------------------
# After sysupgrade install packages:
# ----------------------------------------------
opkg update

opkg install diffutils
opkg install minidlna file
rm /etc/config/minidlna-opkg
opkg install sqlite3-cli
opkg install gdisk
opkg install kmod-fs-ext4 e2fsprogs block-mount
opkg install samba36-server
rm /etc/config/samba-opkg
rm /etc/samba/smb.conf.template-opkg
opkg install rsyncd
opkg install nano
opkg install kmod-fs-exfat
opkg install smartmontools
opkg install hd-idle
rm /etc/config/hd-idle-opkg
opkg install hdparm
opkg install luci-app-minidlna

# ----------------------------------------------
# Recover /mnt/data partition
# ----------------------------------------------

df -Th

gdisk /dev/sda

## GPT fdisk (gdisk) version 1.0.1
## ()...)
## Found valid MBR and corrupt GPT. Which do you want to use? (Using the
## GPT MAY permit recovery of GPT data.)
##  1 - MBR
##  2 - GPT
##  3 - Create blank GPT
##
Your answer: 2

Command (? for help): w   

# Final checks complete. About to write GPT data. THIS WILL OVERWRITE EXISTING
# PARTITIONS!!

Do you want to proceed? (Y/N): y
# OK; writing new GUID partition table (GPT) to /dev/sda.

# ----------------------------------------------
# reboot
# ----------------------------------------------
reboot

No script to speak of, just a plain-jane build that removes some packages and adds some others

make image PROFILE="wd_mybooklive" PACKAGES="(packages here)" FILES="files/"

with the packages string consisting of packages I want out of the box:

  • luci-ssl
  • since I will probably never use pppoe on an MBL:
    -ppp -ppp-mod-pppoe -luci-proto-ppp
  • and also never will serve DHCP from it:
    -dnsmasq -odhcpd -odhcpd-ipv6only
  • but I want samba:
    luci-app-samba36 samba36-server
  • or, alternatively, cifsd (which I didn't use recently, so this would probably now be ksmbd):
    kmod-fs-cifsd cifsd-tools
  • and for some MBLs I am now on snapshot, which don't have samba36 anymore:
    luci-app-samba4 samba4-server
  • and file system tools for mounting, formatting and drive monitoring:
    block-mount fdisk gdisk e2fsprogs hdparm smartmontools
  • and some other stuff I want to have available:
    rsync rsyncd mc nano screen htop

And the files directory containing a full directory structure with one file, etc/config/network, which is just the default /etc/config/network but lan changed to proto dhcp:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option proto 'dhcp'

That's all. No high-class magic here. I deliberately left in the firewall package even though it is not used, in case I want to use the box somewhere out of my local network sometime in the future.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.