Weird port forwarding problem

Hello,

I'm running Openwrt 19.07.2 x86 as a VM on Proxmox. Everything works fine except for one: port forwarding. I have a VLAN as DMZ, and inside that I have a web server accepting connections on port 443.

If I set the external port to anything other than 443 (while keeping the internal one 443), then the port forwarding fails (cannot access it from WAN). In other words, I have to make sure that the internal port and the external one to be the same to make it working. I'm fairly sure it wasn't the case.

/etc/config/network snippet:

config interface 'vlan_dmz'
        option ifname 'eth0.110'
        option proto 'static'
        option ipaddr '192.168.110.1'
        option netmask '255.255.255.0'

/etc/config/firewall:

config zone
        option name 'dmz'
        option family 'ipv4'
        option output 'ACCEPT'
        option network 'vlan_dmz'
        option forward 'REJECT'
        option input 'REJECT'
...

config forwarding
        option src 'lan'
        option dest 'dmz'

...

config forwarding
        option src 'dmz'
        option dest 'wan'
...

config redirect
        list proto 'tcp'
        option src_dport '8443'
        option dest_ip '192.168.110.100'
        option src 'wan'
        option name 'Some web app'
        option target 'DNAT'
        option dest 'dmz'
        option reflection '0'
        option dest_port '443'
...

Any help is much appreciated.

Issue resolved - Software flow offloading was enabled. Once disabled the port forwarding works normally.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.