Weird (?) behaviour of LAN ports

Hi everybody.

Thanks to the help in this forum I managed to install OpenWRT snapshot on a Fritz!Box 7530 including modem setup etc. Now I'm facing some weird behaviour that I did not observe during my initial trials/first runs: my Fritz!Box is connected to the phone line and via lan1 to an ethernet switch. The ethernet switch connects various devices. I wanted to connect some of these devices directly to the Fritz!Box instead (lan2 and lan3) but then thigs get weird - if I ping the router (Fritz!Box) continuously now and then I lose connection - this is also seen in the LuCI webinterface (Network/Interfaces) where e.g. my br-lan is shown as 0.0.0.0. After a few seconds connection is back for a couple of minutes before again connection is lost.

As I doubt that this is normal behaviour I was wondering whether there is any explanation? Do I have a config error I should fix to avoid other (hitherto unknown) problems? Or is the simplest solution just: leave all devices connected to the switch :-)?

Thanks in advance for any suggestions/ideas.
KR

Here's my /etc/config/network (more or less a copy what forum members provided to me :-)) if that helps:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxx'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'b'
        option ds_snr_offset '0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr 'xxx'

config device
        option type '8021q'
        option ifname 'dsl0'
        option vid '2'
        option name 'dsl0.2'

config device
        option type 'bridge'
        option name 'br-dsl'
        list ports 'br-lan.2'
        list ports 'dsl0.2'

config interface 'wan'
        option device 'br-dsl'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'

Your configuration still has a bridge on the WAN port, which even contains the LAN bridge as a member. There is no need for that.

You should be able to replace the last two sections with a single one like this (i.e. remove the br-dsl section, and change the device for the wan section):

config interface 'wan'
        option device dsl.2'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'

(This may not necessarily do anything about your issue with the LAN bridge, but it would be a good change in any case.)

Thanks! Any improvements are welcome! I implemented yours already and DSL connection/LAN is still working :-). I'll check the disconnects later (have to physically rearrange them) - maybe someone else has some other ideas :-)!

KR

Can you draw a diagrram of your network topology (a photo of a sketch on paper is sufficient)? Importantly, what devices are connected via ethernet -- for example, some USB-C hubs with ethernet will freak out when the host goes to sleep or is disconnected, and they will cause the entire network to go down.

From where are you pinging the router? A wired system connected directly to the FB? A wired host connected to the switch? Or a wireless host?

Do all connections suffer the dropouts at the same time? Have you tried pinging other hosts on the network simlutaneously? What about internet access -- does that get interrupted at the same time?

Have you verified that all of your cables are working properly and that there isn't a potential switching loop?

Thanks for taking time to think about my problem.

I'll try to draw a basic sketch (I hope I covered the main part of the network):

FB ... FritzBox (router, connection to internet)
UMS ... unmanaged switch
PC ... Windows 11 PC
AP ... access point (GL.iNet B1300)
---, | ... wired connection
behind the Devolo Powerline other hosts are connected :slight_smile:

Setup with "broken ping":
image

The pinging was always conducted from the PC via wired connection (to the FB). If I change the wired connection from the UMS to the FB directly the disconnects suddenly occur (same cables = cables seem to be okay).
I'll have to check whether other systems can still ping the router/access the internet (that's a to do, but has to wait for the next weekend unfortunately as I'm off site for the main part of the week). I haven't tried pinging other hosts from the PC, but doubt that it works as the FB seems to "reset" it's ports somehow.

"working setup":
image

A switching loop might be the case (no clue how to sort this out), but I could also disconnect the UMS from the FB and see what happens if I directly connect the PC to the FB without the UMS and ping the FB...
Thanks!
KR

This seems to implicate the switch as the problem. Likely a failing device (I’ve seen this happen with devices that have capacitors that are degrading). Try replacing the switch.

thanks @psherman and SORRY for a mixup. Changed the sentence (currently struggling with DNS settings :-():
If I change the wired connection from the UMS to the FB directly the disconnects suddenly occur (same cables = cables seem to be okay).