Weird behavior after changing some settings: some pages are not reachable, other yes

Hi,
I'm rebuilding my network in another way, using VLANs instead of subnetting, I'm just creating two vlans for the 'iot' and 'guest' zones:

but I'm facing a weird issue, as soon as I apply some settings and I reload the network, half of the configurations of the access point (WAX206) stop working and I have to import a backup.

I'm still able to login to LuCi or SSH and editing the network but when I try to reload the network I get a time out:

root@WAX206:~# service network restart
Command failed: Request timed out
Command failed: Request timed out
Command failed: Request timed out
Command failed: Request timed out
Command failed: Request timed out

From the LuCi pages I'm still able to view some pages but not others, for example the processes page oir upgrade-backup yes, but the network or overview no...

This is my config now that is stucked again:

root@WAX206:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd96:6d81:03e4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.2'
	option ipaddr '192.168.1.3'

config device
	option type 'bridge'
	option name 'vlan'
	option ipv6 '0'
	list ports 'lan4'
	list ports 'vlan.20'
	list ports 'vlan.30'

config bridge-vlan
	option device 'vlan'
	option vlan '20'
	list ports 'lan4:t'
	list ports 'vlan.20:t'

config bridge-vlan
	option device 'vlan'
	option vlan '30'
	list ports 'lan4:t'
	list ports 'vlan.30:t'

config interface 'guest'
	option proto 'static'
	option device 'vlan.30'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.4'
	option type 'bridge'

config device
	option name 'vlan.20'
	option type '8021q'
	option ifname 'vlan'
	option vid '20'
	option ipv6 '0'

config device
	option name 'vlan.30'
	option type '8021q'
	option ifname 'vlan'
	option vid '30'
	option ipv6 '0'

root@WAX206:~#

I only created a new interface 'iot' and all is freezed again... before I created the interface all was working as expected, also the 'guest' VLAN clients etc... but I have to create another interface and I'm unable to do.

Read the documentation as you have deviated too much from it. You need only one device (already there, the br-lan) , 3 bridge vlans (lan,iot, guest), and the 3 interfaces.

1 Like

Wait, I restarted all the procedure from scratch and all was working as expected until the reboot, I don't know wha is going on, but I think something weird with LuCi, like cache nvram or similar...

This setup was working perfectly for 10-15 minutes, until the reboot (or reload the networks, like before), I can't understand...

root@WAX206:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd96:6d81:03e4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.2'
	option ipaddr '192.168.1.3'

config device
	option type 'bridge'
	option name 'vlan'
	list ports 'lan4'
	list ports 'vlan.20'
	list ports 'vlan.30'
	option ipv6 '0'

config bridge-vlan
	option device 'vlan'
	option vlan '20'

config bridge-vlan
	option device 'vlan'
	option vlan '30'

config device
	option name 'vlan.20'
	option type '8021q'
	option ifname 'vlan'
	option vid '20'
	option ipv6 '0'

config device
	option name 'vlan.30'
	option type '8021q'
	option ifname 'vlan'
	option vid '30'
	option ipv6 '0'

config interface 'iot'
	option proto 'static'
	option device 'vlan.20'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

config interface 'guest'
	option proto 'static'
	option device 'vlan.30'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

Now I can SSH into the device, I can open -only some- luci pages, and the wireless interfaces are down.

If I try to reload them:

root@WAX206:~# service network restart
Command failed: Request timed out

But I can ping the WAX206 from everywhere in my network

root@R4S:~# ping 192.168.1.3
PING 192.168.1.3 (192.168.1.3): 56 data bytes
64 bytes from 192.168.1.3: seq=0 ttl=64 time=0.842 ms
64 bytes from 192.168.1.3: seq=1 ttl=64 time=0.622 ms
64 bytes from 192.168.1.3: seq=2 ttl=64 time=0.569 ms

why it's semi-frezed at the reboot? Any command/suggestion? I can edit the network settings using vim/nano, but I can't restart the interfaces.

That's very weird!

Some weird logs:

daemon.notice procd: /etc/rc.d/S50uhttpd: Skipping invalid Lua prefix "/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua"

br-lan: port 1(lan1) entered blocking state
br-lan: port 3(lan3) entered blocking state
br-lan: port 4(lan4) entered disabled state

I found the if I kill netifd the LuCi interface is working again, but all the interfaces/network is down obviously.

This is the full booting log:

...cut...

Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.187501] ramoops: using 0x10000@0x42ff0000, ecc: 0
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.204647] OF: /thermal@1100b000: could not get #nvmem-cell-cells for /efuse@10206000/calib@198
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.216505] OF: /ethernet@1b100000/mac@0: could not get #nvmem-cell-cells for /spi@1100d000/flash@0/partitions/partition@1c0000/macaddr@7fff4
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.229355] OF: /ethernet@1b100000/mdio-bus/switch@0/ports/port@5: could not get #nvmem-cell-cells for /spi@1100d000/flash@0/partitions/partition@1c0000/macaddr@7fffa
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.248091] cryptd: max_cpu_qlen set to 1000
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.254177] SCSI subsystem initialized
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    0.258047] libata version 3.00 loaded.
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.262817] clocksource: Switched to clocksource arch_sys_counter
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.269372] NET: Registered PF_INET protocol family
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.274366] IP idents hash table entries: 8192 (order: 4, 65536 bytes, linear)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.281996] tcp_listen_portaddr_hash hash table entries: 256 (order: 0, 4096 bytes, linear)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.290394] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.298172] TCP established hash table entries: 4096 (order: 3, 32768 bytes, linear)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.305971] TCP bind hash table entries: 4096 (order: 4, 65536 bytes, linear)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.313193] TCP: Hash tables configured (established 4096 bind 4096)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.319625] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.326190] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.333266] NET: Registered PF_UNIX/PF_LOCAL protocol family
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.338958] PCI: CLS 0 bytes, default 64
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.345317] workingset: timestamp_bits=46 max_order=17 bucket_order=0
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.354397] squashfs: version 4.0 (2009/01/31) Phillip Lougher
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.360257] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.404279] mt7622-pinctrl 10211000.pinctrl: invalid group "pwm_ch7_2" for function "pwm"
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.415746] mt-pmic-pwrap 10001000.pwrap: unexpected interrupt int=0x1
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.430034] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.437143] printk: console [ttyS0] disabled
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.461610] 11002000.serial: ttyS0 at MMIO 0x11002000 (irq = 125, base_baud = 1562500) is a ST16650V2
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.470925] printk: console [ttyS0] enabled
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.479294] printk: bootconsole [uart8250] disabled
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.509700] 11004000.serial: ttyS1 at MMIO 0x11004000 (irq = 126, base_baud = 1562500) is a ST16650V2
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.519570] 1100c000.serial: ttyS2 at MMIO 0x1100c000 (irq = 130, base_baud = 17499995) is a MediaTek BTIF
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.529325] serial serial0: tty port ttyS2 registered
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.534897] mtk_rng 1020f000.rng: registered RNG driver
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.540482] random: crng init done
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.546432] loop: module loaded
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.549968] mtk-ecc 1100e000.ecc: probed
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.556370] spi-nand spi2.0: Toshiba SPI NAND was found.
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.561689] spi-nand spi2.0: 256 MiB, block size: 128 KiB, page size: 2048, OOB size: 128
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.569932] mtk-snand 1100d000.spi: ECC strength: 12 bits per 512 bytes
Sun Jan 29 15:04:08 2023 kern.info kernel: [    0.578042] [BBT] BMT.v2 is found at 0x7ff
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.582348] 17 fixed-partitions partitions found on MTD device spi2.0
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.588865] OF: Bad cell count for /spi@1100d000/flash@0/partitions
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.595154] OF: Bad cell count for /spi@1100d000/flash@0/partitions
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.601619] OF: Bad cell count for /spi@1100d000/flash@0/partitions
Sun Jan 29 15:04:08 2023 kern.err kernel: [    0.607899] OF: Bad cell count for /spi@1100d000/flash@0/partitions
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.614274] Creating 17 MTD partitions on "spi2.0":
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.619146] 0x000000000000-0x000000080000 : "Preloader"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.625335] 0x000000080000-0x0000000c0000 : "ATF"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.630602] 0x0000000c0000-0x000000140000 : "Bootloader"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.636846] 0x000000140000-0x0000001c0000 : "Config"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.642768] 0x0000001c0000-0x0000002c0000 : "Factory"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.649455] 0x0000002c0000-0x0000028c0000 : "firmware"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.705658] 2 fixed-partitions partitions found on MTD device firmware
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.712186] Creating 2 MTD partitions on "firmware":
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.717156] 0x000000000000-0x000000600000 : "kernel"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.722362] 0x000000600000-0x000002600000 : "ubi"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.727363] 0x0000028c0000-0x000004ec0000 : "firmware_backup"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.782028] 0x000004ec0000-0x0000056c0000 : "CFG"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.797550] 0x0000056c0000-0x000005ac0000 : "RAE"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.807631] 0x000005ac0000-0x000005bc0000 : "POT"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.813856] 0x000005bc0000-0x000005fc0000 : "Language"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.824343] 0x000005fc0000-0x0000061c0000 : "Traffic"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.832178] 0x0000061c0000-0x0000062c0000 : "Cert"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.838517] 0x0000062c0000-0x0000063c0000 : "NTGRcryptK"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.845366] 0x0000063c0000-0x0000068c0000 : "NTGRcryptD"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.857411] 0x0000068c0000-0x0000069c0000 : "LOG"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    0.863644] 0x0000069c0000-0x000007000000 : "User_data"
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.254282] mtk_soc_eth 1b100000.ethernet eth0: mediatek frame engine at 0xffffffc0093e0000, irq 140
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.264045] i2c_dev: i2c /dev entries driver
Sun Jan 29 15:04:08 2023 kern.err kernel: [    1.269212] mtk-wdt 10212000.watchdog: IRQ index 0 not found
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.275025] mtk-wdt 10212000.watchdog: Watchdog enabled (timeout=31 sec, nowayout=0)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.284487] NET: Registered PF_INET6 protocol family
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.290171] Segment Routing with IPv6
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.293869] In-situ OAM (IOAM) with IPv6
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.297820] NET: Registered PF_PACKET protocol family
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.302973] 8021q: 802.1Q VLAN Support v1.8
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.308254] pstore: Using crash dump compression: deflate
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.324610] mtk-pcie 1a143000.pcie: host bridge /pcie@1a143000 ranges:
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.331167] mtk-pcie 1a143000.pcie: Parsing ranges property...
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.337104] mtk-pcie 1a143000.pcie:      MEM 0x0020000000..0x0027ffffff -> 0x0020000000
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.479298] mtk-pcie 1a143000.pcie: PCI host bridge to bus 0000:00
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.485499] pci_bus 0000:00: root bus resource [bus 00-ff]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.490981] pci_bus 0000:00: root bus resource [mem 0x20000000-0x27ffffff]
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.497858] pci_bus 0000:00: scanning bus
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.502068] pci 0000:00:00.0: [14c3:3258] type 01 class 0x060400
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.508261] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x1ffffffff 64bit pref]
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.518268] pci_bus 0000:00: fixups for bus
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.522460] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 0
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.529169] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.537247] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 1
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.544326] pci_bus 0000:01: scanning bus
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.548540] pci 0000:01:00.0: [14c3:7915] type 00 class 0x000280
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.554728] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.562052] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.569382] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.577346] pci 0000:01:00.0: supports D1 D2
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.581611] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.588254] pci 0000:01:00.0: PME# disabled
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.592754] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.636345] pci_bus 0000:01: fixups for bus
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.640541] pci_bus 0000:01: bus scan returning with max=01
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.646145] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.652779] pci_bus 0000:00: bus scan returning with max=01
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.658370] pci 0000:00:00.0: BAR 0: no space for [mem size 0x200000000 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.666025] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x200000000 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.674030] pci 0000:00:00.0: BAR 8: assigned [mem 0x20000000-0x201fffff]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.680814] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.688640] pci 0000:01:00.0: BAR 2: assigned [mem 0x20100000-0x20103fff 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.696468] pci 0000:01:00.0: BAR 4: assigned [mem 0x20104000-0x20104fff 64bit pref]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.704292] pci 0000:00:00.0: PCI bridge to [bus 01]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.709255] pci 0000:00:00.0:   bridge window [mem 0x20000000-0x201fffff]
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.716158] pcieport 0000:00:00.0: assign IRQ: got 145
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.721300] pcieport 0000:00:00.0: enabling device (0000 -> 0002)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.727409] pcieport 0000:00:00.0: enabling bus mastering
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.732845] mtk-pcie 1a143000.pcie: msi#0 address_hi 0x0 address_lo 0x44d9d0c0
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.740218] pcieport 0000:00:00.0: PME: Signaling with IRQ 145
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.746117] pcieport 0000:00:00.0: saving config space at offset 0x0 (reading 0x325814c3)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.754298] pcieport 0000:00:00.0: saving config space at offset 0x4 (reading 0x100006)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.762295] pcieport 0000:00:00.0: saving config space at offset 0x8 (reading 0x6040000)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.770382] pcieport 0000:00:00.0: saving config space at offset 0xc (reading 0x10000)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.778296] pcieport 0000:00:00.0: saving config space at offset 0x10 (reading 0xc)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.785955] pcieport 0000:00:00.0: saving config space at offset 0x14 (reading 0x0)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.793608] pcieport 0000:00:00.0: saving config space at offset 0x18 (reading 0x40010100)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.801865] pcieport 0000:00:00.0: saving config space at offset 0x1c (reading 0x4200000)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.810039] pcieport 0000:00:00.0: saving config space at offset 0x20 (reading 0x20102000)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.818304] pcieport 0000:00:00.0: saving config space at offset 0x24 (reading 0x0)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.825958] pcieport 0000:00:00.0: saving config space at offset 0x28 (reading 0x0)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.833611] pcieport 0000:00:00.0: saving config space at offset 0x2c (reading 0x0)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.841259] pcieport 0000:00:00.0: saving config space at offset 0x30 (reading 0x0)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.848912] pcieport 0000:00:00.0: saving config space at offset 0x34 (reading 0x50)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.856652] pcieport 0000:00:00.0: saving config space at offset 0x38 (reading 0x0)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.864305] pcieport 0000:00:00.0: saving config space at offset 0x3c (reading 0x20191)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.872723] mtk-pcie 1a145000.pcie: host bridge /pcie@1a145000 ranges:
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    1.879266] mtk-pcie 1a145000.pcie: Parsing ranges property...
Sun Jan 29 15:04:08 2023 kern.info kernel: [    1.885100] mtk-pcie 1a145000.pcie:      MEM 0x0028000000..0x002fffffff -> 0x0028000000
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.112884] mtk-pcie 1a145000.pcie: Port1 link down
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.117912] mtk-pcie 1a145000.pcie: PCI host bridge to bus 0001:00
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.124104] pci_bus 0001:00: root bus resource [bus 00-ff]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.129589] pci_bus 0001:00: root bus resource [mem 0x28000000-0x2fffffff]
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.136474] pci_bus 0001:00: scanning bus
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.142330] pci_bus 0001:00: fixups for bus
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.146521] pci_bus 0001:00: bus scan returning with max=00
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.152609] mtk_hsdma 1b007000.dma-controller: MediaTek HSDMA driver registered
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.201826] mt7530 mdio-bus:00: configuring for fixed/2500base-x link mode
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.209180] mt7530 mdio-bus:00: Link is Up - 2.5Gbps/Full - flow control rx/tx
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.218824] mt7530 mdio-bus:00 lan1 (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7531 PHY] (irq=146)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.239028] mt7530 mdio-bus:00 lan2 (uninitialized): PHY [mt7530-0:02] driver [MediaTek MT7531 PHY] (irq=147)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.258773] mt7530 mdio-bus:00 lan3 (uninitialized): PHY [mt7530-0:03] driver [MediaTek MT7531 PHY] (irq=148)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.278428] mt7530 mdio-bus:00 lan4 (uninitialized): PHY [mt7530-0:04] driver [MediaTek MT7531 PHY] (irq=149)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.442879] mt7530 mdio-bus:00 wan (uninitialized): PHY [mdio-bus:07] driver [RTL8221B-VB-CG 2.5Gbps PHY] (irq=POLL)
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.454354] DSA: tree 0 setup
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.458505] UBI: auto-attach mtd7
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.461839] ubi0: default fastmap pool size: 10
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.466386] ubi0: default fastmap WL pool size: 5
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.471082] ubi0: attaching mtd7
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.552478] ubi0: scanning is finished
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.559937] ubi0: attached mtd7 (name "ubi", size 32 MiB)
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.565359] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.572232] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.579022] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.585982] ubi0: good PEBs: 256, bad PEBs: 0, corrupted PEBs: 0
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.591981] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.599203] ubi0: max/mean erase counter: 9/3, WL threshold: 4096, image sequence number: 1673427024
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.608332] ubi0: available PEBs: 0, total reserved PEBs: 256, PEBs reserved for bad PEB handling: 39
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.617560] ubi0: background thread "ubi_bgt0d" started, PID 524
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.618680] block ubiblock0_0: created from ubi0:0(rootfs)
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    2.629048] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.640528] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.647843] Freeing unused kernel memory: 384K
Sun Jan 29 15:04:08 2023 kern.info kernel: [    2.672925] Run /sbin/init as init process
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.677015]   with arguments:
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.679973]     /sbin/init
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.682671]   with environment:
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.685814]     HOME=/
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    2.688166]     TERM=linux
Sun Jan 29 15:04:08 2023 user.info kernel: [    2.868843] init: Console is alive
Sun Jan 29 15:04:08 2023 user.info kernel: [    2.872348] init: - watchdog -
Sun Jan 29 15:04:08 2023 user.info kernel: [    3.189542] kmodloader: loading kernel modules from /etc/modules-boot.d/*
Sun Jan 29 15:04:08 2023 user.info kernel: [    3.214626] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
Sun Jan 29 15:04:08 2023 user.info kernel: [    3.230940] init: - preinit -
Sun Jan 29 15:04:08 2023 kern.info kernel: [    3.498854] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
Sun Jan 29 15:04:08 2023 kern.info kernel: [    3.508939] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
Sun Jan 29 15:04:08 2023 kern.info kernel: [    3.518727] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Sun Jan 29 15:04:08 2023 kern.info kernel: [    3.525703] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.608273] UBIFS (ubi0:1): Mounting in unauthenticated mode
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.614038] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 611
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.636773] UBIFS (ubi0:1): recovery needed
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.699986] UBIFS (ubi0:1): recovery completed
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.704529] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.712358] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.722281] UBIFS (ubi0:1): FS size: 17268736 bytes (16 MiB, 136 LEBs), max 146 LEBs, journal size 1015809 bytes (0 MiB, 7 LEBs)
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.733855] UBIFS (ubi0:1): reserved for root: 815644 bytes (796 KiB)
Sun Jan 29 15:04:08 2023 kern.notice kernel: [    5.740291] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID FF909A00-5FB8-47A8-BBED-94BA32EFE149, small LPT model
Sun Jan 29 15:04:08 2023 user.info kernel: [    5.755650] mount_root: switching to ubifs overlay
Sun Jan 29 15:04:08 2023 kern.warn kernel: [    5.764458] overlayfs: null uuid detected in lower fs '/', falling back to xino=off,index=off,nfs_export=off.
Sun Jan 29 15:04:08 2023 user.debug kernel: [    5.778207] urandom-seed: Seeding with /etc/urandom.seed
Sun Jan 29 15:04:08 2023 user.info kernel: [    5.842853] procd: - early -
Sun Jan 29 15:04:08 2023 user.info kernel: [    5.846074] procd: - watchdog -
Sun Jan 29 15:04:08 2023 user.info kernel: [    6.392330] procd: - watchdog -
Sun Jan 29 15:04:08 2023 user.info kernel: [    6.397518] procd: - ubus -
Sun Jan 29 15:04:08 2023 user.info kernel: [    6.454211] procd: - init -
Sun Jan 29 15:04:08 2023 user.info kernel: [    6.706914] urngd: v1.0.2 started.
Sun Jan 29 15:04:08 2023 user.info kernel: [    6.740523] kmodloader: loading kernel modules from /etc/modules.d/*
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.763559] GACT probability on
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.767278] Mirror/redirect action on
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.774271] u32 classifier
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.776985]     input device check on
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.780636]     Actions configured
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.788217] Loading modules backported from Linux version v6.1-rc8-0-g76dcd734eca2
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.795817] Backport generated by backports.git v5.15.81-1-41-g02e352527db5
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    6.853645] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    6.866308] mt7915e 0000:01:00.0: assign IRQ: got 145
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.871432] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    6.877539] mt7915e 0000:01:00.0: enabling bus mastering
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.918320] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a
Sun Jan 29 15:04:08 2023 kern.info kernel: [    6.918320]
Sun Jan 29 15:04:08 2023 kern.debug kernel: [    7.010784] mtk-pcie 1a143000.pcie: msi#0 address_hi 0x0 address_lo 0x44d9d0c0
Sun Jan 29 15:04:08 2023 kern.info kernel: [    7.029181] mt7622-wmac 18000000.wmac: N9 Firmware Version: _reserved_, Build Time: 20220630094834
Sun Jan 29 15:04:08 2023 kern.info kernel: [    7.071160] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20220929104113a
Sun Jan 29 15:04:08 2023 kern.info kernel: [    7.071160]
Sun Jan 29 15:04:08 2023 kern.info kernel: [    7.209233] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20220929104145
Sun Jan 29 15:04:08 2023 kern.info kernel: [    7.258404] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20220929104205
Sun Jan 29 15:04:08 2023 user.info kernel: [    7.411769] kmodloader: done loading kernel modules from /etc/modules.d/*
Sun Jan 29 15:04:08 2023 user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Sun Jan 29 15:04:08 2023 user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: started, version 2.88 cachesize 1000
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-nftset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sun Jan 29 15:04:08 2023 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jan 29 15:04:08 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 names
Sun Jan 29 15:04:08 2023 authpriv.info dropbear[1357]: Not backgrounding
Sun Jan 29 15:04:09 2023 daemon.notice wpa_supplicant[1467]: Successfully initialized wpa_supplicant
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: bonding
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: 8021ad
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: 8021q
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: macvlan
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: veth
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: bridge
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: Network device
Sun Jan 29 15:04:09 2023 user.notice : Added device handler type: tunnel
Sun Jan 29 15:04:09 2023 daemon.notice procd: /etc/rc.d/S50uhttpd: Skipping invalid Lua prefix "/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua"
Sun Jan 29 15:04:10 2023 daemon.warn netifd: You have delegated IPv6-prefixes but haven't assigned them to any interface. Did you forget to set option ip6assign on your lan-interfaces?
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.713922] mtk_soc_eth 1b100000.ethernet eth0: Link is Down
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.726295] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.735210] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.741411] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.751639] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.758115] br-lan: port 1(lan1) entered blocking state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.763400] br-lan: port 1(lan1) entered disabled state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.770310] device lan1 entered promiscuous mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.774968] device eth0 entered promiscuous mode
Sun Jan 29 15:04:10 2023 daemon.notice netifd: Interface 'lan' is enabled
Sun Jan 29 15:04:10 2023 daemon.notice netifd: Interface 'lan' is setting up now
Sun Jan 29 15:04:10 2023 daemon.notice netifd: Interface 'lan' is now up
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.787982] mt7530 mdio-bus:00 lan2: configuring for phy/gmii link mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.797428] br-lan: port 2(lan2) entered blocking state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.802666] br-lan: port 2(lan2) entered disabled state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.809876] device lan2 entered promiscuous mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.819315] mt7530 mdio-bus:00 lan3: configuring for phy/gmii link mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.829221] br-lan: port 3(lan3) entered blocking state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.834490] br-lan: port 3(lan3) entered disabled state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.841574] device lan3 entered promiscuous mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.851209] mt7530 mdio-bus:00 lan4: configuring for phy/gmii link mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.862968] mt7530 mdio-bus:00 lan4: Link is Up - 1Gbps/Full - flow control off
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.870790] br-lan: port 4(lan4) entered blocking state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.876053] br-lan: port 4(lan4) entered disabled state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.883618] device lan4 entered promiscuous mode
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.890382] br-lan: port 4(lan4) entered blocking state
Sun Jan 29 15:04:10 2023 kern.info kernel: [    9.895645] br-lan: port 4(lan4) entered forwarding state
Sun Jan 29 15:04:10 2023 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Sun Jan 29 15:04:10 2023 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jan 29 15:04:10 2023 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Jan 29 15:04:16 2023 daemon.err uhttpd[1701]: [info] luci: accepted login on / for root from 192.168.1.10

Hmmm I think I've fixed it but I don't know what is/was the issue.

I disabled the vlan list option from the bridged vlans ports but all is working like before, I'm not understanding what is going on. Is this normal?

Now:

config device
	option type 'bridge'
	option name 'vlan'
	option ipv6 '0'
	list ports 'lan4'

Before

config device
	option type 'bridge'
	option name 'vlan'
	list ports 'lan4'
	list ports 'vlan.20'
	list ports 'vlan.30'
	option ipv6 '0'

Full config now:

config device
	option type 'bridge'
	option name 'vlan'
	option ipv6 '0'
	list ports 'lan4'

config bridge-vlan
	option device 'vlan'
	option vlan '20'

config bridge-vlan
	option device 'vlan'
	option vlan '30'

config device
	option name 'vlan.20'
	option type '8021q'
	option ifname 'vlan'
	option vid '20'
	option ipv6 '0'
	option acceptlocal '1'

config device
	option name 'vlan.30'
	option type '8021q'
	option ifname 'vlan'
	option vid '30'
	option ipv6 '0'
	option acceptlocal '1'

config interface 'iot'
	option proto 'static'
	option device 'vlan.20'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

config interface 'guest'
	option proto 'static'
	option device 'vlan.30'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

Full config before:

config device
	option type 'bridge'
	option name 'vlan'
	list ports 'lan4'
	list ports 'vlan.20'
	list ports 'vlan.30'
	option ipv6 '0'

config bridge-vlan
	option device 'vlan'
	option vlan '20'

config bridge-vlan
	option device 'vlan'
	option vlan '30'

config device
	option name 'vlan.20'
	option type '8021q'
	option ifname 'vlan'
	option vid '20'
	option ipv6 '0'

config device
	option name 'vlan.30'
	option type '8021q'
	option ifname 'vlan'
	option vid '30'
	option ipv6 '0'

config interface 'iot'
	option proto 'static'
	option device 'vlan.20'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

config interface 'guest'
	option proto 'static'
	option device 'vlan.30'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

Now I also can't re-add the VLAN to the VLAN-bridge, because there aren't listed

But they are here and are working like they are tagged, I can't understand

Read again the DSA example. You are not following it and you end up having a non operational configuration.
There are no vlan bridge device or vlan.XY in the example.

1 Like

But now is working, so I should have do it correctly. I’ll read the DSA tutorial anyway!

1 Like

I tried to read but I'm not understanding it sorry, probably because I'm doing it mentally different and now I can't understand my current setup, because all is working perfectly but I haven't tagged the vlans that are using all the same cable/port (n4), so how is this possible ?

My config is 3 posts above.

Thanks

It may not be 'broken', but it is almost guaranteed to not be 'working' as you expect because the syntax is wrong.

Reset your config again... post the default network file. We can show you had to add one VLAN, and then you can replicate the recipe for the rest.

Please define what VLANs you want to create and how they will be connected to the physical ports (tagged, untagged, which ports, etc.).

1 Like

Thanks for the reply! ...unfortunaly asll is working as I want (no access to lan from iot and guest zone and homekit working in iot zone), but I don't know how I've done it, and my goal is to understand, not to have things working without know how I've done it :smiley:

So I want to follow your suggestion and make all again:

Basically my goal is to have two VLANs 'iot' and 'guest' and the 'lan' interfaces. I would assign to the 'lan' interface the 'Magnifico' wireless interface (that is my main network with 192.168.1.x) and the 'iot' and 'guest' wireless interfaces assigned to the same 'iot' and 'guest' VLANs. All of these interface should use the port n 4 of the (DSA) switch.

Exactly like as it was in my previous configuration (see image) but with 2 VLANs zone for IoT and Guest instead of the subnets (the IPs of the VLAN could be 192.168.10 and .20, but it's not important).

Here's my resetted config:

Network

root@WAX206:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd96:6d81:03e4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.2'
	option ipaddr '192.168.1.3'

And firewall that I haven't resetted because I can re-use the same zones (or at least follow the old rules to avoid forgetfulness)

Summary
root@WAX206:~# cat /etc/config/firewall 

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'
	list network 'lan'

config zone
	option name 'guest'
	option output 'ACCEPT'
	option input 'DROP'
	option forward 'DROP'

config forwarding
	option src 'guest'
	option dest 'lan'

config rule
	option name 'Guest DHCP'
	list proto 'udp'
	option src 'guest'
	option dest_port '67-68'
	option target 'ACCEPT'

config rule
	option name 'Guest DNS'
	option src 'guest'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'Block guest LAN'
	option src 'guest'
	option dest 'lan'
	option target 'DROP'
	list proto 'all'
	list dest_ip '192.168.1.0/24'

config zone
	option name 'iot'
	option output 'ACCEPT'
	list device 'wl0-ap0'
	option input 'DROP'
	option forward 'DROP'

config forwarding
	option src 'iot'
	option dest 'lan'

config rule
	option src 'iot'
	option dest_port '53'
	option target 'ACCEPT'
	option name 'IoT allow DNS'

config rule
	option name 'IoT DHCP '
	list proto 'udp'
	option src 'iot'
	option dest_port '67-68'
	option target 'ACCEPT'

config rule
	option target 'ACCEPT'
	option src 'iot'
	option name 'IoT port 80'
	list proto 'tcp'
	list proto 'udp'
	option src_port '80'

config rule
	option dest_port '443'
	option target 'ACCEPT'
	option src 'iot'
	option name 'IoT port 443'

config rule
	option dest_port '5353'
	option target 'ACCEPT'
	option src 'iot'
	list proto 'udp'
	option name 'IoT mDNS port 5353'
	list dest_ip '224.0.0.251'
	list dest_ip 'ff02::fb'

config rule
	list proto 'tcp'
	option src 'iot'
	option dest_port '25050'
	option target 'ACCEPT'
	option name 'Netatmo port 25050'

config rule
	option src 'iot'
	option dest 'lan'
	option target 'DROP'
	list dest_ip '192.168.1.0/24'
	option name 'Block IoT to LAN'
	list proto 'all'

config rule
	option name 'LAN to IoT'
	option src 'lan'
	option target 'ACCEPT'
	option dest 'iot'
	list proto 'all'

config rule
	option target 'ACCEPT'
	option src_port '51826-51827'
	option dest_port '51826-51827'
	option src 'iot'
	option dest 'lan'
	option name 'HomeKit connectivity'
	option enabled '0'

root@WAX206:~# 

Same for wireless interface that I can "recycle":

root@WAX206:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option band '2g'
	option channel 'auto'
	option country 'US'
	option cell_density '0'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option key ''
	option ssid 'Magnifico_IoT'
	option encryption ''

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option cell_density '0'
	option country 'US'
	option htmode 'HE80'
	option channel '40'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option encryption ''
	option key '!'
	option network 'lan'
	option ssid 'Magnifico'
	option macfilter 'deny'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Magnifico Guest'
	option encryption ''
	option key ''

Hope that's all correct, thanks a lot for the info and help!

To confirm that I understand your intentions... the additional networks (192.168.5.0/24 and 192.168.3.0/24) are only used for wifi?

If that's the case, you don't need to use VLANs at all.

Will either or both of these networks be used on both radios or just one (2.4G / 5G)?

1 Like

Yes exactly, and yes, now I'm using them without vlan indeed (with both zones in a separated subnet), but I want to try to use them as vlans...

My last setup was working, this setup

Summary
config device
	option type 'bridge'
	option name 'vlan'
	option ipv6 '0'
	list ports 'lan4'

config bridge-vlan
	option device 'vlan'
	option vlan '20'

config bridge-vlan
	option device 'vlan'
	option vlan '30'

config device
	option name 'vlan.20'
	option type '8021q'
	option ifname 'vlan'
	option vid '20'
	option ipv6 '0'
	option acceptlocal '1'

config device
	option name 'vlan.30'
	option type '8021q'
	option ifname 'vlan'
	option vid '30'
	option ipv6 '0'
	option acceptlocal '1'

config interface 'iot'
	option proto 'static'
	option device 'vlan.20'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

config interface 'guest'
	option proto 'static'
	option device 'vlan.30'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

But the vlan are not tagged, I don't understand what I've done.

VLANs only apply if you’re using Ethernet. This is useful and necessary if you have multiple APs that you want to use to broadcast the guest and iot networks, or if you have wired devices you wish to connect to those networks.

Does this apply in your situation?

The AP is wired to my router, and on the AP there are 3 wireless interface, all connected to the same cable, yes I know that I can make all without vlan, but it's just to understand better and because I would connect also my Television (wired) to it.

For example, now again, my "new" setup is working untill I reboot the AP, when after the boot I lost all the network interface, with this setup (before the reboot all was working):

Summary
root@WAX206:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd96:6d81:03e4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.2'
	option ipaddr '192.168.1.3'

config device
	option type 'bridge'
	option name 'br-vlan'
	option ipv6 '0'
	list ports 'br-vlan.20'
	list ports 'br-vlan.30'
	list ports 'lan4'

config bridge-vlan
	option device 'br-vlan'
	option vlan '20'
	list ports 'br-vlan.20:t'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-vlan'
	option vlan '30'
	list ports 'br-vlan.30:t'
	list ports 'lan4:t'

config interface 'iot'
	option proto 'static'
	option device 'br-vlan.20'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'

config interface 'guest'
	option proto 'static'
	option device 'br-vlan.30'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.2'
	option type 'bridge'


If I put out of the bridge the two vlans, all is working again, I don't understand why...

The reason things are keep breaking because your VLAN syntax is entirely wrong, so everything is choking when it boots up.

Let's do it for VLAN 20 (iot), starting from your reset/default config...
add the following:

config bridge-vlan
	option device 'br-lan'
	option vlan '20'
	list ports 'lan4:t'

config interface 'iot'
	option proto 'static'
	option device 'br-lan.20'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'

This will put VLAN 20 on br-lan.20 and it will be connected to ethernet as a tagged network on port lan 4 (assuming that this is the physical port used to connect to the switch). From there, you'll need to configure your switch to expect VLAN 20 tagged on the corresponding port. And then, for the TV, you'll want to set that switch port as an access port for VLAN 20 (i.e. untagged/PVID/native/default) depending on the switch, the methods may be a bit different, but the concept is the same.

2 Likes