Weird amazon Android app behavior

Hi all, wondering if anyone else has encountered weird amazon app behavior on android 12 while connected to their openwrt network. I was running friendlywrt 21.02 on my nanopi r4s their latest available release and I'm using TP-Link Archer2600 with stock firmware as a dumb ap, (had it running latest openwrt stable 21.02 on it set up as a dumb ap with same issues). Using amazon app on my android 12 phone I get the "uh-oh something went wrong" page when accessing the cart everything else works fine, it's just the cart. I currently switched the nanopi to the March 28 release found here: and same thing occurs. I can access the cart on mobile network and on wifi at work. I can also access it when I'm connected to a VPN through an app on the phone (tried two different providers). To test further I'm gonna try the amazon app on another android 10 phone connected to the same network. Using the app on an iphone works fine, the cart is accessable. I occasionally get asked to verify it's me in the app and have to fill out a captcha when searching for things, which also only happens on the openwrt network. Right now the openwrt is very vanilla, it's just DHCP to the cable modem in bridge mode on the wan and wan6 interfaces, and DHCP server on the lan interface with all default settings. No services running and no custom rules anywhere. I'm looking for any input anyone may have. Later today I will try running just the Archer2600 with stock firmware connected to the modem in bridge mode to see if it still happens.

Have you tried deleting the Amazon App cache?

App Info > Storage and cache > clear cache

Yeah, the first things I tried were clearing cache and data for the app, I tried different versions too.

What wireless encryption are you using?

WPA2 only with AES


  • Two 2 Vanilla 21.02 ~ WPA2 AES

  • Android 10 ~ No Cart ~ Cache Cleared

  • Android 12 ~ No Cart ~ Cache Cleared

  • iPhone ~ Cart ~ random captcha

  • Mobile Network ~ Right as Rain!

  • VPN via phone's app thru your OpenWRT Vanillas ~ Right as Rain!

Is this correct?

I'd get the version of the app.

Confirm the phone is using the same encryption as the wireless interface.

One vanilla 21.02

TP-Link Archer C2600 stock as access point

Android 10 ~ Right as Rain

Android 12 ~ No Cart ~ random captcha ~ Cache Cleared

iPhone ~ Right as Rain

Mobile Network ~ Right as Rain!

VPN via phone's app thru OpenWRT Vanilla ~ Right as Rain!

New development, email from ISP that there is an insecure device on my network. Will investigate what it could be.

1 Like

Pop into your routers and peek at the system log..

Guessing one of them routers has a clue.

Issue resolved, I decided to focus on my phone specifically. It's rooted, so I added amazon app to magisk's zygisk deny list and cleared the app data. After I signed in it's all right as rain, everything works. I'm not sure what specifically triggered the error only on the openwrt network at home since everything worked on my work's wifi and mobile, but it had to do with the app detecting root and not the network. Thanks for all the help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.