Weird 5Ghz Speeds on a WRT3200ACM

Hi everyone! After a long fight with my 5Ghz wifi network, I was finally able to connect all devices in my apartment to it. But now I noticed a very strange behavior where some devices have full 80Mhz while others stay in 20Mhz only all the time.

Currently, I have three devices connected to the network as a test:

  • A Playstation 4 Pro - This has full 80Mhz access;
  • A LG Smart TV - This has full 80Mhz access;
  • An Android 10 Phone - This has only 20Mhz access (I have three cell phones here and all of them show the same results. Also my laptop with a AC card can only connect at 20Mhz in this network too);

This is what I see on my wifi status page, if it helps:
image
(in order is the TV, the PS4 and the Android phone).

Im running both 2.4Ghz and 5Ghz on this router. Radio2 (Marvell 88W8887) is disabled as recommended here in the forum.

In the first network, I have this:
Marvell 88W8964 802.11acn
Channel: 36 (5.180 GHz) | Bitrate: 44 Mbit/s

in the second:
Marvell 88W8964 802.11bgn
Channel: 8 (2.447 GHz) | Bitrate: 6 Mbit/s

Here is my /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country '00'
        option htmode 'VHT80'
        option legacy_rates '0'
        option channel '36'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option country '00'
        option legacy_rates '1'
        option channel '8'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'SSID1'
        option encryption 'psk2'
        option key 'REMOVED'

config wifi-device 'radio2'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option htmode 'VHT80'
        option channel '124'
        option disabled '1'

config wifi-iface 'default_radio0'
        option network 'lan'
        option ssid 'SSID2'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option key 'REMOVED'
        option wmm '0'

You can notice that my 2.4Ghz has only 20Mhz enabled. The idea was to make this network reach as far as possible while having the 5Ghz being the fastest one, but now I'm open to any suggestions since this is not really working as intended.

My /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8a:2b89:4298::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '192.168.1.23'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'
        option peerdns '0'
        option dns '192.168.1.23'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'
        option auto '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

I have manual DNS because I run Pi Hole. Not sure about the VLAN (never set it up from what I remember, I suppose this is default?).

Any suggestions on how to set this up? Any help is appreciated. Thanks!