WDS, VLAN and Fast transition

Hi, I'v got a situation on which I need some advice.
I want to extend my current network with an acces point (WDS).

This is my current setup"
I'v got 3 TP-link Archer C7 with openwrt 19.07.2.

    • Main Router
      VLAN: LAN(1), IOT(2)
      WIFI: AMWN (2.4Ghz), AMWN-5G (5ghz, WDS AP) and AMWN-IOT (2.4ghz, WDS AP)
      Interface: WAN, LAN (AMWN, AMWN-5G) and AMWN-IOT (2.4ghz)
      802.11r Fast Transition enabled
    • AP1
      WIRED
      VLAN: LAN(1)
      WIFI: AMWN (2.4Ghz), AMWN-5G (5ghz)
      Interface: LAN (AMWN, AMWN-5G)
      802.11r Fast Transition enabled
    • AP2: WIRELESS REPEATER (WDS)
      VLAN: LAN(1), IOT(2)
      WIFI: AMWN-5G (5ghz, WDS client, AP) and AMWN-IOT (2.4ghz, WDS client, AP)
      Interface: LAN (AMWN-5G) and AMWN-IOT
      802.11r Fast Transition enabled

Questions
The questions are about the extending my network with AP2. Old situation with main router en AP1 everything works fine.

  1. I created a network bridge (repeater) over 5ghz connected to AMWN-5G. Next I made an acces point on 5ghz to extend the wifi with same SSID with help of this guide. I could only get is to work on fixed channel 149 which is ok, but took some time to figure out.
  • Sometimes connected devices do not have internet connection, probably after switching acces points. After reconnecting to same network problem is solved. What could be the cause?
  1. I also want to extend the IOT network, for better coverage for my iot-devices. I created a network bridge (repeater) over 2.4ghz connected to AMWN-IOT. So I also made VLAN iot, interface and bridged AMWN-IOT, static IP in de range of IOT subnet. DHCP disabled etc. For testing purpose I used a different SSID (openwrt) for the AP.
  • On this network the devices won't receive an IP-adres. What could be the cause?
  1. Is it possible / usefull to also create a bridge over AMWN (2.4Ghz) besides AMWN-5G for better performance?

Thank you for your time!

My config files of AP3

network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd59:29f8:6242::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.0.1'
	option ipaddr '192.168.0.3'
	option stp '1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 1'
	option vid '2'

config interface 'iot'
	option stp '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.4.2'
	option netmask '255.255.255.0'
	option gateway '192.168.4.1'
	option ifname 'eth1.3'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t'

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option channel '149'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option ssid 'AMWN-5G'
	option key '****'
	option encryption 'psk2'
	option ft_over_ds '1'
	option nasid '100003'
	option mobility_domain '4f57'
	option ft_psk_generate_local '1'
	option ieee80211r '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option channel '7'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option network 'iot'

config wifi-iface 'wifinet2'
	option ssid 'AMWN-5G'
	option device 'radio0'
	option mode 'sta'
	option key '****'
	option wds '1'
	option network 'lan'
	option encryption 'psk2'
	option bssid '70:4f:57:'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'sta'
	option key '****'
	option network 'iot'
	option encryption 'psk2'
	option ssid 'AMWN-iot'
	option bssid '76:4F:57:'
	option wds '1'

dhcp


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'
	list server '192.168.0.1'

config dhcp 'lan'
	option interface 'lan'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'iot'
	option interface 'iot'
	option ignore '1'