WDS on kernel 6.6

Hi,
I have being using WDS successfully for years between Belkin RT3200 and another one when both were on kernel 5.15.
I do not have anymore the second RT3200 and was starting using WDS between RT3200 and Cudy WR3000. Both were using 6.1 kernel without any issue and still there is no issue.
However when I updated both routers to kernel 6.6 or just one of them I started having issues. The WDS seems to be fine, but no clients can connect to the bridge. I reverted back to 6.1 for both of the routers and all is fine.
Today I received my new Xiaomi AX3000T and I was trying to do a WDS bridge with Cudy WR3000, but again the same problem - connection between the routers is reported to be fine but, no clients can connect. Xiaomi is running latest 6.6 snapshot , and Cudy 6.1 snapshot from March. After 4 hours of trying to solve it - I gave up and here I am to seek for a help.
What I found out is that the I can not log in to the master WDS AP - Xiaomi AX3000T when it is setup as WDS AP, even when Cudy is powered off. If I change from WDS AP to AP - there is no problem the clients to connect to Xiaomi.
I would appreciate any help with it.
Here are some details:

        "kernel": "6.6.35",
        "hostname": "X3000T",
        "system": "ARMv8 Processor rev 4",
        "model": "Xiaomi Mi Router AX3000T",
        "board_name": "xiaomi,mi-router-ax3000t",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r26833-6b16eaf840",
                "target": "mediatek/filogic",
                "description": "OpenWrt SNAPSHOT r26833-6b16eaf840"

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'IK5'
	option time_advertisement '2'
	option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
	option key ''
	option network 'lan'
	option encryption 'psk2+ccmp'
	option dtim_period '3'
	option ieee80211r '1'
	option mobility_domain '2222'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option bss_transition '1'
	option disassoc_low_ack '0'
	option pmk_r1_push '1'
	option wds '1'

Cudy

       "kernel": "6.1.81",
        "hostname": "CudyWr3000",
        "system": "ARMv8 Processor rev 4",
        "model": "Cudy WR3000 v1",
        "board_name": "cudy,wr3000-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r25580-85ad6b9569",
                "target": "mediatek/filogic",
                "description": "OpenWrt SNAPSHOT r25580-85ad6b9569"
config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'sta'
	option ssid 'IK5'
	option encryption 'psk2'
	option key ''
	option bss_transition '1'
	option time_advertisement '2'
	option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
	option dtim_period '3'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option wds '1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'IK5'
	option encryption 'psk2'
	option key ''
	option ieee80211r '1'
	option mobility_domain '2222'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option network 'lan'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'IK2.4'
	option encryption 'psk2+ccmp'
	option key ''
	option ieee80211r '1'
	option mobility_domain '2222'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option network 'lan'


PS: I am using at the moment x86( Fujitsu Futuru s920) - cable - Belkin RT3200 (for the testing without wifi) - cable - Xiaomi AX3000T - wds - Cudy WR3000
Edit 2: Looking further, I noticed a difference between RT3200 and Cuy on 6.1 and Xioami on 6.6.
In Luci under Network- Interface- Devices - Add new configurtion you can choose the Wifi devices in 6.1, but not in 6.6. Can it be the case that in 6.6 Wds Ap is not bridged to br-lan be default?
6.6

6.1

You are now forced to select network from wifi side because it never worked from bridges side.

1 Like

Well It seems I fixed it, however by just clicking on configurate on the Wifi device

Under wireless - network it is still default "lan".
I am not sure if that's the right approach - at least it worked for me, however it will be nice if we update the wiki page. I know @bluewavenet did a fantastic job with it lately.
Now br-lan looks like this:
image

Another strange thing was that I could not connect to the WDS AP if I used the same ESSID as in the Belkin - namely "IK", once I added 1 at the end - "IK51" it worked.
Thanks
Kind regards
KRassi

First add link to outdared wiki page.

WDS does not link with non-openwrt devices very often, as there is no WDS standard, just a bunch of normally unused MAC addresses used as path breadcrumbs.

Here it is https://openwrt.org/docs/guide-user/network/wifi/wifiextenders/wds

All of my devices are Openwrt, however Belkin and Cudy are on 6.1. Xiaomi on 6.6.
Wds AP was Belkin and now Xiaomi.

Check if the WDS option is set in right places.

Well, I already mentioned, that it is working now. However I am not sure if my setup is correct, as it is not according to wiki. And there is a difference how it is setup in 6.1 and 6.6 apperantly.

The wiki page does not say anything about adding wifi as a bridge port from bridge side.

I know, but that's how I got it working. Actually it is not a port. Here is my working config:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxx'
	option packet_steering '2'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config device
	option name 'wan'
	option macaddr 'xxxxx'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option name 'phy0-ap0'

config device
	option name 'phy1-ap0'


To be honest I didn't understand, how should I set it up from wiki. Can you help me to test it out?


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi'
	option band '2g'
	option channel '1'
	option htmode 'HE40'
	option country 'PA'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'IK2.4'
	option encryption 'psk2'
	option key 'xxxxx'
	option ieee80211r '1'
	option mobility_domain '2222'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option time_advertisement '2'
	option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
	option bss_transition '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option band '5g'
	option channel '100'
	option htmode 'HE160'
	option country 'PA'
	option cell_density '0'
	option txpower '26'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'IK51'
	option time_advertisement '2'
	option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
	option key 'xxxxxx'
	option network 'lan'
	option encryption 'psk2+ccmp'
	option dtim_period '3'
	option ieee80211r '1'
	option mobility_domain '2222'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option bss_transition '1'
	option disassoc_low_ack '0'
	option wds '1'


Only problem I see with your setup is 11R together with proxy_arp when later will make arp database very sticky and not handle movements well/at all.

1 Like

Another observation: enabling WED on the WDS AP results in no internet via the WDS client. LAN connection seems to be fine. I have stoped bridger as well, just to be sure it doesn't cause issues as well.

I think I saw fix for that on github, but not sure if it was applied. Just disable WED if it "does not work"....

Yep, that's what I did. All fine for now - 4h. Probably you have seen this one : https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=75081235b804e1e9246aaf538fda98e26f0af27c. I even updated the WDS client ( cudy wr3000) to latest snapshot as I was scared not to break anything. So far so good. It is time to retire Belkin RT3200... and go on second hand market.
Kr
K

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.