WDS not working on Netgear Nighthawk R7500v1


I have a two R7500v1 routers flashed with openwrt 21.02.1 r16325-88151b8303
I set up multiple wifi networks on the first router. On one of the wifi networks I changed the wifi setting to Access Point (WDS).
On the other R7500v1 I connected to the first router with Client (WDS) setting. I used this tutorial with luci: https://openwrt.org/docs/guide-user/network/wifi/atheroswds
Except of the last step it worked. So my pc gets an IP address from the wired connection to the wds client. But if I add a new wifi network with mode Access Point the connection to the main router is lost. So it works as a wireless client but I would like to have a wds repeater. What did I do wrong? Or is WDS not possible with this router?

WDS is broken in the current 21.02.0 and 21.02.1 builds. This issue is already fixed in the snapshot builds. See more details below:


Thank you :blush:. I lost lots of hours this night because of this :see_no_evil:
So if I use 21.02.0 rc3 it will work?

I haven't tested 21.02.0 rc3 myself, but according to the discussion on the reported bug above it seems it should work.

Thanks I will try :slight_smile:

I tried it with OpenWrt 21.02.0-rc3 r16172-2aba3e9784 on both routers. But there is the same error, when I add a new WIFI interface the connection to the WDS AP ist lost. I see the connection in the wireless stations but I can't ping anything. If I disable the new wifi, it works. So I don't have a repeater, I only have I client bridge.
Is there a problem with WDS on my routers?