WDS link for private and guest network VLANs

I want to extend the coverage of the private and guest Wi-Fi network. How should I configure to be able to use via a WDS link?

Set up a secondary router / dumb AP (same network, no routing, no dhcp) on same networks, add "option wds 1" both sides, both networks.

A wireless client can only connect to a single access point, you cannot have the same repeater client connect to two networks on the main router.

Easiest solution is probably to use the 5GHz band for one network, and the 2.4GHz band for the other. You can bridge the APs on the repeater, so your clients can connect to any band.

The other.soolution is to tunnel one network inie the other, for example using GRE.

1 Like

Whoopsie, you're right: when I was using WDS (3yrs ago) I only had one SSID and 1 radio! I had extrapolated without checking, my bad.

1 Like

Yes, I know that only one client can connect to an AP. What I'm asking is how to make the traffic from the private and guest network go through the same WDS link since in the second router there is only one radio and I can't use 5GHz as return. I think the solution is on the VLANs side or as you say, tunnels.
I used Batman but I see that it is convenient when there are several mesh points and not a point to point as in my case.

Ready! And how to make the guest traffic go through the WDS link?

Here is the configuration of each point:

NODE 1

root@Archer_C60:~# cat /etc/config/wireless

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option country 'AR'
        option legacy_rates '0'
        option htmode 'HT20'

config wifi-iface 'wifinet4'
        option device 'radio1'
        option mode 'ap'
        option ssid 'WDS'
        option encryption 'psk2+ccmp'
        option wds '1'
        option hidden '1'
        option ifname '2G_ap_wds'
        option key 'password'
        option network 'lan'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Private_Wi-Fi'
        option ifname '2G_ap'
        option encryption 'psk2+ccmp'
        option key 'password'

config wifi-iface 'wifinet3'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Guest_Wi-Fi'
        option encryption 'psk2+ccmp'
        option ifname '2G_ap_guest'
        option key 'password'
        option network 'guest'
root@Archer_C60:~# cat /etc/config/network

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option delegate '0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t'
        option vid '2'
        option description 'guest'

config interface 'guest'
        option proto 'static'
        option type 'bridge'
        option ifname 'eth0.2'
        option delegate '0'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

NODE 2

 root@CPE210:~# cat /etc/config/wireless
 
 config wifi-device 'radio0'
         option type 'mac80211'
         option channel '11'
         option hwmode '11g'
         option path 'platform/ahb/18100000.wmac'
         option country 'AR'
         option legacy_rates '0'
         option htmode 'HT20'
 
 config wifi-iface 'wifinet0'
         option network 'lan'
         option wds '1'
         option ssid 'WDS'
         option encryption 'psk2+ccmp'
         option device 'radio0'
         option mode 'sta'
         option key 'password'
         option ifname '2G_sta_wds'
 
 config wifi-iface 'wifinet1'
         option ifname '2G_ap'
         option ssid 'Private_Wi-Fi'
         option encryption 'psk2+ccmp'
         option device 'radio0'
         option mode 'ap'
         option network 'lan'
         option key 'password'
 
 config wifi-iface 'wifinet2'
         option ifname '2G_ap_guest'
         option ssid 'Guest_Wi-Fi'
         option encryption 'psk2+ccmp'
         option device 'radio0'
         option mode 'ap'
         option key 'password'
         option network 'guest'
``

root@CPE210:~# cat /etc/config/network

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '192.168.1.2'
        option gateway '192.168.1.1'
        list dns '192.168.1.11'

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.2.2'
        option gateway '192.168.2.1'
        option delegate '0'
        list dns '192.168.2.1'
        option netmask '255.255.255.0'

See this thread, where I explained the process I followed in a similar situation:

https://forum.openwrt.org/t/trunking-over-wireless/27517/16

2 Likes

Thank you all! :smiley:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.