WDS Extension - Client router IP issue

Hi! I've got the following setup:

Internet --> AP1 (WDS Master) --> AP2 (WDS Client & WDS Master) <-- AP3 (WDS Client)

I'm trying to extend the WDS with AP2 as AP3 is too far away to communicate with AP1.

The WDS Master config is the same on AP1 and AP2. The WDS Client works fine when connecting directly to AP2.

AP3 seems to have problems obtaining an IP address for any clients connecting to it. Do you have any idea why?

Master config looks like this:

config wifi-iface 'default_radio1_wds'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'BLAHBLAHBLAH'
        option ssid 'MYSSID'
        option encryption 'psk2+ccmp'
        option wds '1'
        option ieee80211r '1'

Client config:

config wifi-iface 'default_radio1_sta'
        option device 'radio1'
        option network 'lan'
        option mode 'sta'
        option key 'BLAHBLAHBLAH'
        option ssid 'MYSSID'
        option encryption 'psk2+ccmp'
        option wds '1'

AP:

config wifi-iface 'default_radio1_ap'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'BLAHBLAHBLAH'
        option ssid 'MYSSID'
        option encryption 'psk2+ccmp'
        option wds '0'
        option ieee80211r '1'

Am I missing a configuration somewhere?

Looking at it, I don't think I need option ieee80211r '1' set on the Master WDS interface but that shouldn't be causing issues with DHCP right?

Thank you!

There is effectively no link between the WDS sta and AP on the middle device. You can try creating two VLANs one for each WiFi and bridging them together.

Thanks for the reply.

There no link between the sta and ap? That's how the instructions here say to set things up:

https://openwrt.org/docs/guide-user/network/wifi/atheroswds

They are both linked to the lan interface, no?

I'm connected to another remote AP that's not trying to extend the WDS and that seems to route just fine.

Yes, they are bridged. I don't know why I said what I said.

Did you try setting a gateway for AP 3?

Also if you set a static IP on a device and connect to AP 3, can you ping any of AP 2 or AP 1?

Hi! Appreciate the responses. You got me thinking :slight_smile: Here's my working config now on WDS with 3 clients - 1 of which is extending the WDS AP itself.

I'm leaving /etc/config/network out of it as there's nothing really special in it other than the client routers having static IP's and they specify the primary routers IP as the gateway.

PRIMARY ROUTER (Netgear R7800) - ~west side of the house

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option txpower '30'
        option channel '157'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID5G'
        option wds '1'
        option encryption 'psk2+ccmp'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option txpower '30'
        option channel '4'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID2G'
        option encryption 'psk2+ccmp'
        option wds '1'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

CLIENT ROUTER (ZBT-1326) - south side, in the garage

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'HT20'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option channel '4'

config wifi-iface 'default_radio0_sta'
        option device 'radio0'
        option network 'lan'
        option mode 'sta'
        option key 'SECRETKEY'
        option ssid 'SSID2G'
        option encryption 'psk2+ccmp'
        option wds '1'

config wifi-iface 'default_radio0_ap'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID2G'
        option encryption 'psk2+ccmp'
        option wds '0'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option channel '157'
        option txpower '15'

config wifi-iface 'default_radio1_sta'
        option device 'radio1'
        option network 'lan'
        option key 'SECRETKEY'
        option ssid 'SSID5G'
        option wds '1'
        option mode 'sta'
        option encryption 'psk2+ccmp'

config wifi-iface 'default_radio1_ap'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID5G'
        option wds '0'
        option encryption 'psk2+ccmp'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

CLIENT ROUTER (ZBT-826) - east side of house. note that this one has option wds '1' set on the ap sections. This is what basically extends the WDS AP for the outside client below.

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option txpower '30'
        option channel '4'

config wifi-iface 'default_radio0_sta'
        option device 'radio0'
        option network 'lan'
        option mode 'sta'
        option key 'SECRETKEY'
        option ssid 'SSID2G'
        option encryption 'psk2+ccmp'
        option wds '1'

config wifi-iface 'default_radio0_ap'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID2G'
        option encryption 'psk2+ccmp'
        option wds '1'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option channel '157'
        option txpower '30'

config wifi-iface 'default_radio1_sta'
        option device 'radio1'
        option network 'lan'
        option key 'SECRETKEY'
        option ssid 'SSID5G'
        option wds '1'
        option mode 'sta'
        option encryption 'psk2+ccmp'

config wifi-iface 'default_radio1_ap'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID5G'
        option wds '1'
        option encryption 'psk2+ccmp'
        option ieee80211r '1'

CLIENT ROUTER (ZBT-826) - north west, outside of house (covers backyard)

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option txpower '30'
        option channel '4'

config wifi-iface 'default_radio0_sta'
        option device 'radio0'
        option network 'lan'
        option mode 'sta'
        option key 'SECRETKEY'
        option ssid 'SSID2G'
        option encryption 'psk2+ccmp'
        option wds '1'

config wifi-iface 'default_radio0_ap'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID2G'
        option encryption 'psk2+ccmp'
        option wds '0'
        option ieee80211r '1'
        option ft_psk_generate_local '1'
        option ft_over_ds '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option noscan '1'
        option short_preamble '1'
        option legacy_rates '0'
        option country 'CA'
        option channel '157'
        option txpower '30'

config wifi-iface 'default_radio1_sta'
        option device 'radio1'
        option network 'lan'
        option key 'SECRETKEY'
        option ssid 'SSID5G'
        option wds '1'
        option mode 'sta'
        option encryption 'psk2+ccmp'

config wifi-iface 'default_radio1_ap'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'SECRETKEY'
        option ssid 'SSID5G'
        option wds '0'
        option encryption 'psk2+ccmp'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

This seems to be working pretty well. I can see outside station will bounce between the east side router and the primary router but it doesn't seem to affect the clients connected to it.

I had a 5th router in a TP Link Archer C7 v2 but there must be something up with that firmware as it was having connectivity issues. As soon as I removed it, everything seemed to stabilize.

All client routers have DHCP disabled on the lan interface (option ignore '1').

Maybe this helps someone :slight_smile:

Thanks!