WDS between 2 routers keep losing connection

I have 2 routers that i am trying to configure for WDS.
Main Router: Archer c6 v3.20
Client Router: Archer c60 v2

I followed this guide to setup my WDS and it does work but only for 5-15 min max and then i lose connection between the two routers.

Main Router Logs
Client Router Logs

One thing i did notice was that even after they lose connection they are still shown as connected on the wireless page on both routers.

Any help will be appreciated!

I guess ditch WDS and use 802.11s instead.

I have been trying to make that work for past 3 days and it never worked...just tried it 1 more time after u said it and it worked 1st try.... :man_shrugging: :man_facepalming:

i guess i will test it for sometime now and see if it works fine

@LoV432 Which version of OpenWRT are you using? There are issues with WDS on 21.02.0 and 21.02.0_rc4. WDS works well on 21.02.0_rc3.

At that time i was using snapshot on archer c6 and 21.02.0 on archer c60....but turns out the issue was with archer c6 openwrt. Its disconnecting almost everything even lan and wan ports so i reverted to TP-Link stock firmware on it and now everything seems to be working fine