WDR4300 can’t get rid of openwrt

I have openwrt on my TP-Link WDR4300 and have spent a ridiculous number of hours researching and trying alll the methods to revert to either stock firmware or DD-wrt and nothing works and I am at wits end .

I tried using TFTPD32 to flash new firmware but nothing downloads when I power on the router holding WPS.

Tried opkg of luci so I can load firmware with the web interface but won’t install luci

Tried wget from google drive of firmware to /temp but can not get the firmware to download to my router

Please, please any suggestions . Nothing I do can get rid of the openwrt .

https://openwrt.org/toh/tp-link/tl-wdr4300#back_to_original_firmware this works as described, but it is essential to prepare the OEM firmware properly (strip it, if it includes the bootloader, don't strip if it doesn't - the resulting image size must have exactly the same size as OpenWrt's factory images). The procedure is guaranteed to work, if you do it properly - if you don't prepare your firmware correctly, there's a high chance to overwrite the wlan calibration data and thereby brick the wlan functionality for good.

If https://openwrt.org/toh/tp-link/tl-wdr4300#de-brick_or_oem_installation_using_the_tftp_recovery will work depends on the version of the installed OEM bootloader, as push-button tftp recovery was only retrofitted in later OEM firmware upgrades and was not part of the early production runs/ early OEM firmwares.


Thanks for your help .

I have a stripped version of the firmware. My point of failure is getting the firmware on the router. No luck with TFTP, or wget

wget (usually http sources only, not https) or scp/ pscp are supported by all versions of OpenWrt.

1 Like

Thanks . Just one more question. Can you point me to a source where I can find the exact SCP cooand to enter to retrieve a bin file from google drive and place it on the router /Tom folder. I am having no luck finding it online

Thanks again

The proper directory on the router is /tmp. This is a RAM disk which means it has lots of space though it is not permanent. Using another directory will try to store the file on the flash, and there isn't enough space for that.

First have the file on your PC not a remote location. Then:

Linux PC:

scp filename.bin root@

Windows PC:

  • Download and install Tera Term
  • Use Tera Term to establish a SSH connection with the router.
  • Pull down the File menu and choose SSH SCP
  • In the top section, put the local file name for From: and /tmp as the To: destination. Click Send.
  • Use the terminal window to run sysupgrade.
1 Like

Thank you so much. This Tera term sounds like exactly what I was looking for

Can I ask you one follow up question? I have been using putty to SSH to my router and then I log into openwrt with root and then my password. The first time i did this , I had to use telenet. I did this a dozen times at least with no issue

I went to do it again so I can use SCP like you suggested. The only thing I did differently was I held the WPS/reset button for a while while the router was both on and off........ but now I can not telenet or SSH to my router no matter what. And I am doing everything the same as I have a dozen times before and this time I just get a blank black screen and nothing more

I don’t think I bricked the router as all the lights are blinking and my iPhone detects an openwrt WiFi network

Any ideas?

Try to connect your PC to the wifi. If that connects, check your network status on the PC to see what the IP of the router is.

What version is installed? Versions after 15 always use ssh never telnet. Old versions use telnet when reset to default settings.