WD My Book random spinup

Hello, I have wd passport USB3, connected to the xiaomi mi router3g, I use it like NAS. When router works couple of days, HDD spinup randomly in random time, when I reboot it, and reset power to the hdd, and router, situation back to the normal, hdparm works as expected. After 1-2 days, situation repeat, and hdparm stop working, nor hd-idle helps, even when I umount drive from the filesystem, and check lsof is empty, it still spinup automatically, are there WD controller issue ? How to diagnose this kind of problem, because WD support useless. Here it is what they are respond to me(see below). If needed, I can solder out something from controller...Option could be to solder arduino external power control watchdog for hdd, but oh, maybe there are another options ? Any ideas ? I want to keep it calm until required, after spindown after 40 minutes of time of inactivity. Can you recommend good USB SATA controller, that listen for my commands ? I can upgrade WD firmware, but there are no guarantee that issue will be solved, it can become even worse. Thanks forward.

me:
okay, thank you Silvia, it seems it is some kind of issue with linux and WD passport controller, because I use original USB, and original power supply, drive connected directly to the usb3. It works correctly when plug in, but after 1-2 days, hdparam tool stops working, and it is not possible to spindown the drive, even when I unmount(or reboot OS) the drive from the linux filesystem tree, the issue are still remains until I unplug external power supply and usb, just after that it starts working correctly for 1 day more. I use ext4 filesystem, if I would update it through windows 7, would it corrupt the ext4 filesystem ? Would I lose data on drive in ext4 case ? Because I do not trust to the windows. Or maybe you have same tool for linux ?

they :
slight_smile:Thank you for your response. I can see from your email that the issue seems to be with Linux Operating System, and that you ask if updating the ext4 filesystem would help or if it will corrupt the data on the drive.

I would recommend contacting Linux Support directly in order to try and resolve this issue, since it is something specific to their operating system.

If after contacting Linux you need further help with the device’s configuration, please reply to this email and we will be happy to assist you further.

Sincerely,
Silvia
Western Digital Service and Support

  1. Does this happen on "normal" / other OS?

  2. Does it keep spinning? what happens after

Western Digital support in this instance is abysmal.

1 Like

Does this help? USB Drive can't go to standby or wakes up seconds after going to standby

2 Likes

Yes, same happen on laptop running x86_64 linux. On laptop I noticed even when I unplug USB3, the drive continue spinning! It keep spinning for hours, after spindown, for 1-2 hours, after spinup again, without any kick, until power reset. But this situation happen when drive working for a while. For short period of time when power on, it works just as expected, hdparm works...

Thanks, yes I have this package installed. But I am not sure if issue related to this particular, because as you can see, it works as expected when just enabled, it stops working after 1-2 days....

upd: tried to remove block-mount, after check lsof were empty, did hd-idle, drive spindown, after spinup immediately. Any other ideas ?

updupd: steps to reproduce

  • unlug/plugin USB3, hd-idle not works,
  • unlug usb3, unlug 12v external power, plug in 12v and USB3, hd-idle works as expected... No more random spinup

@vitaliy-kuzmich, welcome to the community!

I'm lost:

  • You noted this issue occurred on another Linux distro, correct?
  • Is your device still connected to the machine in this scenario?
  • Can you access data?

To be honest, I own a HD Passport, I've never seen it spin down while powered on.

Are you saying that you want to place the drive into another enclosure?

Did you ask WD about such a tool?

1 Like

@lleachii Thank you. Small mistake, I have not passport but My Book (whatever).
So you tell that passport does not spindown ? Did you try to use hdparm ? I think any drive can be spindown, at least for 'home usage' class of devices.
I use next command : hdparm -B 1 -S 30 /dev/sda but it stops working after I I/O a lot, even -B 255 does not help.
Yes, I have same issue on other linux distro, I think it is specific to the WD. So I contacted to the WD support, I've made another request to them, in order to explain how APM works, what values are correct, what tools should I use, etc... (waiting for response)

Issue happen when the device connected to the host, and (even)unmounted from the filesystem, basically it happen randomly.

I am just thinking to replace SATA controller, but not sure which would works...

WD support told that they does not support linux at all, which is strange, I am sure they are using Linux on their servers, but ignore support for this system in their products.

UPD: I found when the drive connected to the router, and I did not use it a lot, it works correctly, but when I write/read many GB, issue occures.

Another thing that I found, this tool(http://idle3-tools.sourceforge.net/) might probably help, but I can't find it owrt repos. WIll test it on laptop. Also there are -J flag, in hdparm tool, it says that it works only on WD Green series, so I did not test it with My Book.

You can correct this error by editing your first posting accordingly.

1 Like

It seems problem were in enabled APM, when I disable it with -B 255 no more random spinup happen, so now I have a question, WTF is APM, and why does it randomly spinup the drive ?


I surmise because of USB3 power controls.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.