Wavlink WN530HG4 (SoC = MT7620A) > 1Gbps port incorrectly capped to 100mbps

Hi all,

Quick overview of my setup:

Hi all!

Quick overview of my setup:

  • Router Wavlink WN530HG4
  • Server (ProxMox), wired to router with cat5e cable
  • Wireless 802.11ac - WISP setup through wlan0 / wlan0-1

This router has 4x100Mb/s LAN ports and 1x1Gbps WAN port, which are all switched on eth0.

ROUTER ethtool eth0

Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 5
        Transceiver: external
        Auto-negotiation: on
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

SERVER ethtool eno1

Settings for eno1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Auto-negotiation: on
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        MDI-X: on (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

Despite ethtool clearly reporting 1000Mb/s on both sides and showing the connection as the MII port on the router, I still get capped at 100Mb/s when transferring files to and from my server. My WLAN is reporting 800mbit/s, so that's hardly the problem either. What could be going wrong?

You realize that mt7620a is a single-core SOC running at 580 MHz? Its routing performance is rather on the low end (it can shine via hardware flow-offloading, but that is limited to 'simple' tasks), in line with its age.

Hi

the factory firmware have its own tricks do offload most of work to switch chip (HW offloading) so CPU will stay mostly idle when transfering files

OWRT is sort of general linux distro, which have no possibility to make such things
ok, there are few NSS builds and similar, but yes, mostly HW offload is problematic

anyway, you could find in firewall page two option
SW offload
HW offload
please try to enable these option, one by one, reboot, and then maybe you will get better result

Thanks for your reply. I tried flicking that offload option on, but it made no difference. Would it help if I just turn this device into a dumb AP and have all the routing etc. done on the main server?

Assuming the routing's the bottleneck, it would.

I'm not sure. At least for device with external gigabit switch (mt7620a+rt8367s connected to port5 of internal switch) I've got >200Mbps wifi<=>lan.