Wavlink WL-WN570HA1 wifi problem

I have one of these devices working as a dump access point and I experience no connections on radio0 2.4
All incoming connections dropping instantly and passing thru mesh to my other access point a Xiaomi Mi4A gigabit.


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option band '2g'
        option cell_density '0'
        option htmode 'HT20'
        option channel 'auto'
        option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'kouloura1'
        option key ' '
        option ieee80211r '1'
        option mobility_domain '123f'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT80'
        option channel 'auto'
        option txpower '16'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'kouloura1'
        option encryption 'psk2'
        option key ' '
        option ieee80211r '1'
        option mobility_domain '123f'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'```

remove legacy_rates (unless you actually need them)

remove all of the 802.11r fast roaming features.

3 Likes

I need the fast roaming features.
I deleted the legacy_rates but I have the same result, it drops the connection immediatly.

Try turning this off anyway. We need to know if this is the cause of the problem.

I removed the other access points. The clients connected but the connection was unstable and practically useless.

Not real likely to help here, but always set your country code, on both radios.

Mobile client OS is programmed to strongly prefer a 5 GHz connection over a 2.4 one when both have the same SSID. I have seen Android leave a nearby strong 2.4 AP and switch to a distant 5 GHz one that was barely receivable.

Did you explicitly disable 802.11r on this ap?

I disabled the 802r from this ap but no connections on radio0 2.4 established.


root@OpenWrt_Outdoor:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/10300000.wmac'
	option band '2g'
	option cell_density '0'
	option htmode 'HT20'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'kouloura1'
	option key ''
	option encryption 'psk2'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option htmode 'VHT80'
	option channel 'auto'
	option txpower '16'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'kouloura1'
	option encryption 'psk2'
	option key ''

root@OpenWrt_Outdoor:~# 

root@OpenWrt_Outdoor:~# cat /etc/openwrt_release
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='23.05.0-rc3'
DISTRIB_REVISION='r23389-5deed175a5'
DISTRIB_TARGET='ramips/mt76x8'
DISTRIB_ARCH='mipsel_24kc'
DISTRIB_DESCRIPTION='OpenWrt 23.05.0-rc3 r23389-5deed175a5'
DISTRIB_TAINTS=''
root@OpenWrt_Outdoor:~#