Wavlink WL-WN532A3 how install openwrt?

Hey guys i have Wavlink WL-WN532A3 model router Official web page is here and I found this topic in this forum while searching openwrt version for my router. Here

What he's saying is that this router is used by different brands with the same hardware (because it's a chinese router). He has the same router i have but other brand's. Other brand's same router link (Winstars WS-WN532A3)

And he says " the openwrt version at this address works perfectly with my router an they have the same hardware. I followed and used the installation instructions the same way." The software verison the he said (wl-wn575a3)

My problem is I tried the specified installation instructions and as told i connected to telnet but telnet tells me this.

But i never installed openwrt on this router

Router's web page is here

I tried failsafe mode and password change methods over and over, but I could not get a result.
I tried telnet username as root and no password , root - root, admin-admin, root - admin. I even used nrack but it didnt.

I'm waiting for your help.

so try TFTP instead

I also tried TFTP, lan1 led blinks fast but tftp operation is not done. is there any way i can tell if tftp is listening?

you can try some other device, and pull the image, but if there's no reaction on the tftp server, it's usually because the firewall's blocking the calls.

There is no option to turn off the firewall. It also does not accept firmware download from the web page. I don't have another device unfortunately.

.... on the host runing the tftp server ...

2 Likes

yes, it is very logical, I will close it and try and let you know the result. but i think the computer is not getting ip address when the router is in tftp mode

did you read the TFTP instructions on the wiki page you liked to, yourself ?

Yes, but I guess I don't know much about tftp I will read again and write about my experiences

try for how to set it up, not the actual files

I did what is stated in the article 192.168.10.100 and I set my settings as firmware.bin but it didn't work. Port 69 seems to be closed I tried 2 different tftp servers, same result

Then your only option is wireshark, or serial console.

the openwrt page says Some devices may have a restricted boot loader that pretends to try TFTP recovery but does not request anything.

In these cases, you may want to flash a working boot loader for that device. A good summary on this topic can be found here. The unlocked bootloader can be found here.
need telnet to change bootloader and i don't know telnet passwords

Indeed, but you don't know if yours is one of those, until you've hooked up a serial console.

1 Like

I solved the problem thanks to you! I downloaded wireshark as you said and I didn't know exactly how to use it, but I noticed something while examining it.

I saw these ip addresses on wireshark

192.168.9.2 and 192.168.9.233

I tried both of these ip addresses and checked wireshark looked at tftp request.
When I typed 192.168.9.2 in my ip address line, I did not see a response in the tftp software. but when i went to wireshark it said it was a tftp request and the file name should be update.bin so i changed opewrt firmware.bin to update.bin and tftp started installing software!

Thank you for your support and suggestions. An admin who is interested in the wiki page can add this solution to the download page. Easier than the other way.

[OpenWrt Wiki] WAVLINK WL-WN575A3

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.