WAVLINK WL-WN531A6 - no wifi interfaces after OpenWrt installation

I'm currently installing openwrt on this router I've got past the installing the Luci stage. I'm now however a bit stuck as when I look at the interfaces tab I see no WiFi interfaces and I also don't have any reference to WiFi in any of the GUI

I think you may have only flashed initramfs-kernel.bin, after you've flashed this and got Luci up you'll need to flash squashfs-sysupgrade.bin and install Luci again via SSH.

@Osbojas did you solve your problem? I do have exactly the same problem. I followed this tutorial: https://openwrt.org/toh/wavlink/wavlink_wl-wn531a6

I flashed the initramfs kernel image rebooted installed luci flashed the sysupgrade image rebooted, reinstalled luci but when I go to network and devices there is no wifi device, only my ethernet ports, bridges and virtual lan interfaces

I tried out a couple of images. I'm currently on this one: OpenWrt 21.02.0-rc3 r16172-2aba3e9784 / LuCI openwrt-21.02 branch git-21.163.64918-ba57ec5 Kernel Version 5.4.124

Hi! I confirm, too, that after upgrading to 21.02.0-RC3, WiFi is missing, while the snapshot image I have installed around February seems to work perfectly. Do the more seasoned users consider this regression as something normal in the release candidate cycle, i.e. to be resolved in the next RC or stable version? Should, for example, expect that when the final stable version comes out that I would be able to upgrade from RC3 without losing the settings and that the WiFi shows up again?

just tested 21.02.3 and everything worked fine via the original gui update path.
(no need to install LuCI, it's allready in current release.)
webcmd.shtml even works in latest wavlink release to backup fw, but "sync" is not supported (any longer?) so be careful.