Wavlink Quantum Dax (‎WL-WN538A8) W-K3_386.9_0_cfe.trx firmware

Hi everyone, I am new in this topic and I am the owner of a Wavlink Quantum Dax (‎WL-WN538A8) router, based on Phicomm K3. The signal device is instable, often the networks drop or disappear (2.4/5Ghz or both) and reset the device does not have any effect on it. I found a Merlin Open WRT firmware (W-K3_386.9_0_cfe.trx) available on chinese forums. I know that I need a Minicom terminal and a TTL to USB interface to flash my device with a *.trx firmware but I do not know exactly which are the steps I have to follow and I do not want to brick the router. Internet is plenty of information but sometimes too much information result a bit confusing, expecially for newbies. Do you have a step by step tutorial (For dummies) that explains how to flash this router? Thank you very much in advance. Kind Regards

1 Like

Guess you should replace the Openwrt firmware with the file you've got.

Hi, do you need both programs, the TFTP server and Minicom?

Setup tftp Server

  • Start dnsmasq tftp server:
    • sudo dnsmasq –port=0 –enable-tftp –tftp-root=/tmp/tftp –tftp-no-blocksize –user=root –group=root

Setup minicom:

  • Install minicom tool:
    • sudo apt install minicom

Yes, if you're doing it from Linux.

If windows, tftpd64 and putty will work.

1 Like

Hi, any idea how to open it? I saw many fotos but no way to open one side without breaking the plastic clips

Tried the wiki page ?

1 Like

There is nothing, only photos. However, Finally, I was able to open it but some clips broke :slightly_smiling_face: I have the TTL to USB converter. Should the motherboard be connected to the power when connected to this converter? Thanks

Ok ...

connect the serial, switch on the device.
don't connect the voltage pin of the serial.

1 Like

Hi, Iwas talking about the same photos you uploaded. However, no one explain how to open the case without breaking plastic clips.

connect the serial, switch on the device.
don't connect the voltage pin of the serial.

If I have to switch on the device, I consider that I have to connect the porwe supply to the motherboard. Thanks

Yes, you do.

1 Like

I tried to follow this steps but now I am stack, since I cannot find the option in TFTPD64 to transfer files.

  1. Download and install Tftpd64 from the Tftpd64 website.
  2. Download the ZIP file containing your router’s firmware update file from the NETGEAR Download Center.
  3. Extract the ZIP file to your desktop. The firmware file format is either .img or .chk.
  4. Using an Ethernet cable, connect your computer directly to your router.
  5. Set your computer to use a static IP address:
  6. Click the Windows icon in the taskbar or press the Windows key on your keyboard. The Start menu displays.
  7. Type network connections.
  8. Click View network connections or press the Enter key.
  9. Right-click Ethernet and select Properties.
  10. Double-click Internet Protocol Version 4 (TCP/IPv4).
  11. Select Use the following IP address and enter the following values:
    * IP address:
    * Subnet mask:
    * Default gateway:
  12. Click OK to save the configuration.
  13. Configure Tftpd64 to connect to your router:
  14. Launch Tftpd64.
  15. In the Server interfaces field, select your computer’s LAN adapter.
  16. In the Host field, enter (the default router IP address).
  17. In the Port field, enter 69 (the default port number for TFTP).
  18. Click the … button next to the Local File field.
  19. Browse to the firmware file that you downloaded and select it.
    7.Caution:* Do not click Put until you are instructed to do so!
  20. Unplug all other Ethernet connections from your router, leaving only your computer connected.
  21. Turn your router off for 10 seconds.
  22. Turn your router back on.
  23. Wait for the Power LED to light orange and start flashing.
  24. (I AM HERE) When the Power LED is flashing, click Put in Tftpd64 to initiate the firmware upload. The upload might take a few minutes.
  25. If the firmware upload is successful, a dialog box appears to confirm the blocks transferred, with a 0 block retransmitted message and a MD5 checksum. If the firmware upload fails, repeat steps 8-11.
  26. Wait about 4 minutes for the router to finish storing the firmware into its flash memory. When finished, the Power LED turns solid white and the wireless LEDs light up.
  27. Return your Ethernet network connection settings in Windows to the previous settings.

As long as serial isn't working, everything else is irrelevant.

Tftp recovery is device/vendor specific, you can't follow some random guide from Netgear, and think it'll work for you.

I was thinking the same about serial. It seems that is not working when I connect it though the Tftpd64 software. since the program does not show anything when connected.

I use a 60cm long cable. ¿Could be this the issue?

Tftpd64 has nothing to do with serial, that's what putty's for.

Could you please tell me a bit more. I am a bit lost and I do not know why there is no communications

Your guess is as good as mine, and I don't own the device.

One, so far, none of you screen shots show an attempt to use a serial connection in Putty.

Two, swap the Tx and Rx pins on the USB TTL.

Three, short the Rx and Tx pinx on the USB TTY, see if you can see you own typing in Putty.

1 Like

Hi, I already swapped TX and RX cables.
I forgot to mention that Putty is always frozen. The text cursor is always green and I am not able to write anything, even if I short RX and TX pins as you suggested. It always returns an error message:"Network error: connection time out"