Warp: You've hit the daily limit for the unauthenticated API

hello

just finish setup warp following wgfc profile. today i see this message any idea how to solve it?

btw warp is free without limitation right?

thanks for help

root@OpenWrt:~# curl --interface cloud https://ipinfo.io
{
  "status": 429,
  "error": {
    "title": "Rate limit exceeded",
    "message": "You've hit the daily limit for the unauthenticated API.  Create an API access token by signing up to get 50k req/month."

Doing the suggested in the reply ?

The message would indicate the opposite, and kill their business model.

1 Like

so i must register with warp+ ?

No one's forcing you, but you seem to need it, for whatever reason.

will think about it, thanks

You ask about warp but show a message that looks like it relates to a different service ipinfo.io. I don't use either product so I may not understand the repationship between the two but it seems like if you want more access to ipinfo.io you would need to subscribe to a higher tier of their service. Before you do that, You may want to make sure you understand how it relates to the warp service if you are only interested in using Warp.

2 Likes

just need get more speed download some file, try download ubuntu file need 4hour, turn warp on suddenly just need 10min to download the iso.

that is the goal, rater i install each device, maybe i can setup 1 warp in my router.

1 Like

As @spence noted, it looks like the error you're seeing is regarding too many requests to the IPInfo website or their API. It doesn't appear to be regarding WARP, but I could be wrong too.

Since it takes CPUs to create a Wireguard connection - overhead plus normal traffic, etc. - the speed will not be as fast with your normal ISP and Warp disabled.

Hope this helps.

just pay 1$ for warp+ for test , still no work in my openwrt.
don't know what wrongs.

no only me have this issue, many member from this isp have same issue. before i have other isp, never happen this issue with other isp, don't know what happen with this isp bandwidth.
i using 50mpbs packages.

btw before setup in my router i test wrap from my pc. after i see the result than i try to setup in my router.

show new message, but checking myip.com still not getting ip from cloudflare just my isp ip.
don't what wrong, time to rest, hope tomorrow can found some miracle

root@OpenWrt:~# curl --interface cloudflare https://ipinfo.io
{
  "ip": "104.28.213.128",
  "city": "Jakarta",
  "region": "Jakarta",
  "country": "ID",
  "loc": "-6.2146,106.8451",
  "org": "AS13335 Cloudflare, Inc.",
  "timezone": "Asia/Jakarta",
  "readme": "https://ipinfo.io/missingauth"
}root@OpenWrt:~#

type or paste code here

Are you sure you aren't NATed ?

What is not working? What did you test and what was the result? Please provide some detail and maybe someone can offer better help.

If curl --interface cloud https://ipinfo.io still returns "title": "Rate limit exceeded" and you are manually testing what ip address is seen, you can use a different service to check your ip address such as ip.me or www.whatismyip.com. There are more as well. If you are mot connecting through warp or a vpn, that result may be due to your new isp using CG-NAT or simmilar and many customers are testing like you are. Also, maybe if you are tunneling, others share the same exit point.
Good luck.

100% double Nat, isp don't give me ip public, they using ip private.

But warp no issue from pc

Anyway I already set 25 at peer configuration

Tomorrow I will submit more detail. Need rest :sleeping::sleeping::sleeping: many thanks

hai,

don't what happen same profile test with wireguard pc work well, but not working in my router
Test from pc with WG on


WG PC off

I think router already connect to warp, but don't why the ip still using my isp not using cloudflare ip

test from router
image


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd89:aaaf:51ea::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.x.1/24'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option metric '10'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option name 'wan'
        option macaddr 'xx:xx:xx:20:75:8B'

config interface 'wanb'
        option proto 'dhcp'
        option device 'lan2'
        option metric '20'

config interface 'zerotier'
        option proto 'dhcp'
        option device 'ztr2qyexzy'

config interface 'cloud'
        option proto 'wireguard'
        option private_key 'xxxxxxxqNlQM4cY132Hille+vCN+oKLl4='
        list addresses '172.16.0.2/32'
        list addresses '2606:4700:110:82b8:b2c9:5992:ac1b:4254/128'
        list dns '1.1.1.1'

config wireguard_cloud
        option description 'Imported peer configuration'
        option public_key 'xxxxxxxxxyiK2H5/1SUtzH0JuVo51h2wPfgyo='
        list allowed_ips '0.0.0.0/0'
        list allowed_ips '::/0'
        option endpoint_host 'engage.cloudflareclient.com'
        option endpoint_port '2408'
        option route_allowed_ips '1'type or paste code here
config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wanb'
        list network 'cloud'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'

just solve the problem

setup from 0 and check each package i use.

this issue only show after install mwan3, remove it done, check myip.com show cloudflare ip.

just thinking how to solve this issue with mwan3 installed , i have second isp for backup.

thanks

This means you configured mwan3 - and now want a different config for Warp. You'll have to check those configs when you decide that you desire to fix it. Feel free to make a new thread when you're ready.

Hope this helps.

Sure next time I will open new thread mwan3+VPN.

Now I setup 2 router, the main router with VPN warp+, second with mwan3 all device connected to router 2

Now everybody is happy. :grin:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.