Wan6 interface has eth1 as device?

I have just transitioned from a D-Link router to the GL-MT6000 and eventually managed to get things working.
However I have this discrepancy -
On D Link router before


On MT6000 now

If I go into Edit there is no separate wan in the dropdown box unless I choose custom and add it but that does not seem right to me?
What should be changed to correct it?

Please let me know if you want me to post config especially as probably a few other errors in there :wink:

Do you use OpenWRT or GLinet OpenWRT-based software?

This is expected with the MT6000. No change needed.

1 Like

OpenWRT flashed yesterday. so 23.05.5

I had a similar issue with wan and PPPoE until I resolved it so a little surprised that this would be considered the norm?

It is common to use @wan there.

1 Like

Is there a problem today with this new router and setup, or you just don’t like the way the config looks? eth1 is definitely the correct WAN interface for this model.

2 Likes

Not that I am aware of thanks.
As mentioned had same issue with wan until I sorted out the PPPoE and that does not say eth1 any more........so I was surprised that wan6 did.

As long as it is not going to cause any issues than I can ignore it......but no I don't like the way it looks :slightly_smiling_face:

Since 2 ports has WAN printed on them one can call one of them potato and other snowman according to standards...

1 Like

I’m not familiar with PPPoE so if you have doubts, post your /etc/config/network for others to review (redacting personal data).

pppoe generally does not use the wan6 interface which is part of the default configuration (which assumes the WAN is "IPoE", or acquire addresses directly by DHCP). The pppoe driver should instantiate and configure a wan_6 connection when the ISP supports v6.

Not sure exactly what you mean but my only reference is the previous install with the same connection as posted.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf0:873e:0c0c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config device
        option name 'lan1'
        option macaddr ''

config device
        option name 'lan2'
        option macaddr ''

config device
        option name 'lan3'
        option macaddr ''

config device
        option name 'lan4'
        option macaddr ''

config device
        option name 'lan5'
        option macaddr ''

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth1'
        option macaddr ''

config interface 'wan'
        option device 'eth1'
        option proto 'pppoe'
        option username ''
        option password ''
        option ipv6 '1'
        option mtu '1492'
        option peerdns '0'
        list dns '9.9.9.9'
        list dns '1.1.1.1'
        list dns '2620:FE::FE'
        list dns '2606:4700:4700::1111'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '9.9.9.9'
        list dns '1.1.1.1'
        list dns '2620:FE::FE'
        list dns '2606:4700:4700::1111'

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'
        option device 'br-guest'
        list dns '9.9.9.9'
        list dns '1.1.1.1'
        option gateway '192.168.1.1'

config device
        option type 'bridge'
        option name 'br-guest'
        option bridge_empty '1'

Interface names vary by model. I think the MT6000 has the 2.5 Gb "wan" port directly connected to the CPU as a separate Ethernet device with no switch. So it would be named eth1. The firstboot scripts take care of this when they build out the default /etc/config/network file.

But on a pppoe ISP, generally it doesn't work to send DHCPv6 packets directly on an eth port. They need to be encapsulated by the ppp driver and sent inside the ppp tunnel as a pppoe packet which eventually leaves by eth1, as specified in the wan section.

Does IPv6 work? When the wan is up, do you also see a wan_6 in the interfaces page (or ip addr show on the CLI)?

No wan_6 -

If you want ip6 you have to change tthe device. Only that.

Change to what though?

to Pppoe-wan

Does your ISP actually support v6? Presently the router is running only a v4 connection and all lans will only support v4 because there is no upstream v6.

that's how it's configured eth1 is the wan port

You can change it to '@wan' if you want to use an alias of the wan connection, but if you look at the wan interface/connection you'll see it is also set to eth1