Wan VLAN tagging with DSA on WRT1900ACS

Kia Ora,

Trying to use DSA on latest snapshot and my ISP requires the following VLAN config:

  • WAN Connection Type: DHCP (Automatic IP/Dynamic IP/IP over Ethernet)
  • 802.1Q: Enabled
  • VLAN ID (802.1Q): 10
  • 802.1P (Priority): 0
  • IP Version: IPv4 or IPv6
  • MTU Size: 1492 or 1500
  • NAT: Enabled

I have tried and tried using both the updated LuCI or directly editing the config but I usually have to reset the router anytime I touch any of the lan ports.

On adjusting the wan either i get a non-functional bridge or 'device not found'.

Edit: I just want to make a working connection, I'll worry about additional VLANs afterward

This is my current swconfig:

NB: forgive the labels as this is from my notes

Cheers in advance.

Haven't checked if VLAN 2 is in use by default but it's often a bad idea to reuse it. Did you add the VLANs one by one? Try that, starting with the one your ISP needs.

Kia ora!

Configure as much as you can of the Wan configuration as you can in luci.
To get DSA to connect to your ISP you will need to edit the "network" config in /etc/config

Add the following under " config interface 'wan' "

option ifname 'wan.10'

save then reboot.

1 Like

I use DSA and need VLAN tagged 20 on WAN, here is my network config which is working perfect:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd00:b77d:4514::/48'
	option packet_steering '1'

config interface 'lan'
	option type 'bridge'
	option ifname 'lan1 lan2'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'wan.20'
	option proto 'dhcp'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config interface 'wan6'
	option ifname 'wan'
	option proto 'dhcpv6'

config device
	option name 'wan.20'
	option type '8021q'
	option ifname 'wan'
	option vid '20'

2 Likes

Thank you, @larrynz

That's all I needed to do was rename the "wan" interface to "wan.10" - ka mau te pai :+1:

Unrelated a bit - there is a "packet steering" option under global network options - will this increase CPU utilisation on a dual core router?

1 Like

Some say it does, some say it doesn't.

On the Xiaomi 4a Gigabit it is enabled by default so I just left it enabled.

1 Like

In the past I've found no real benefit in switching packet steering on for my wrt1900acs & wrt32x. YMMV depending on your router.

I have found enabling irqbalance on these routers though helps with cpu wifi load balancing.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.