WAN port on router acts as LAN

Does it get an IP address from DHCP? If not it could be MAC address blacklisting from the provider side. You can power off the devices for say 30 minutes and try again, or spoof a working MAC on the wan interface of your router.

Are there 1 or 2 CPU Interfaces on this router? You can verify that on the switch page.
Also post the output of ip -s link

It gets IP from DHCP. I have powered down. Let me wait and power up again.

For the TP-Link. It has one CPU interface. Here is the screenshot: https://imgur.com/a/3qI2qZC

Output of

ip -s link

BusyBox v1.28.4 () multi-call binary.

Usage: ip [OPTIONS] address|route|link|neigh|rule [COMMAND]

OPTIONS := -f[amily] inet|inet6|link | -o[neline]
COMMAND :=
ip addr add|del IFADDR dev IFACE | show|flush [dev IFACE] [to PREFIX]
ip route list|flush|add|del|change|append|replace|test ROUTE
ip link set IFACE [up|down] [arp on|off] | show [IFACE]
ip neigh show|flush [to PREFIX] [dev DEV] [nud STATE]
ip rule [list] | add|del SELECTOR ACTION

You should probably install the package ip-full and repeat the command.

1 Like

ip link will also do.

1 Like

Output of ip link on the TP-Link MR3420

root@OpenWrt:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    link/ether 98:da:c4:7a:1f:48 brd ff:ff:ff:ff:ff:ff
6: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 98:da:c4:7a:1f:49 brd ff:ff:ff:ff:ff:ff
22: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 98:da:c4:7a:1f:48 brd ff:ff:ff:ff:ff:ff
23: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 98:da:c4:7a:1f:48 brd ff:ff:ff:ff:ff:ff
25: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 98:da:c4:7a:1f:48 brd ff:ff:ff:ff:ff:ff

Looks fine and it seems that there is no eth1 as I suspected from the bootlogs.
Can you verify with dmesg | grep eth1 ?

1 Like

It returned with empty. Nothing was found

So this is the image of my Network/Switch Luci Page for my device that has this problem
https://imgur.com/a/eE0OMhz

I realized that unlike the TP-Link, there is no really specified WAN port and the CPU interface is always down. Is there anyway to activate the CPU interface as seen in the TP-Link below

Where is 5?

There is no 5.

Port 5 is the wan port since it is member of vlan 2. The other 4 ports belong to the lan.

I realized something. Anytime I restart my router and I execute

uci show network

The VLAN 0 and VLAN 1 ports always change. Is this normal?

Could you post here an example?

1m

The WAN Cable is connected to Port 5 on my router and this is the output of

uci show network

root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd4a:226f:5b58::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.1'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan_dev=device
network.lan_dev.name='eth0.1'
network.wan=interface
network.wan.ifname='eth0.2'
network.wan.proto='dhcp'
network.wan_dev=device
network.wan_dev.name='eth0.2'
network.wan6=interface
network.wan6.ifname='eth0.2'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 3 5t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='4 5t'
root@OpenWrt:~# 

I now switched the internet Cable to Port 4 and restarted the router and this is the output

root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd4a:226f:5b58::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.1'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan_dev=device
network.lan_dev.name='eth0.1'
network.wan=interface
network.wan.ifname='eth0.2'
network.wan.proto='dhcp'
network.wan_dev=device
network.wan_dev.name='eth0.2'
network.wan6=interface
network.wan6.ifname='eth0.2'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 4 5t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='3 5t'```

I just realized the index of the ports starts from 0. That's why when I change the WAN port on the Network/Switch Luci web Page it output changes by (port number - 1).
I guess you can ignore the previous post.

Do you think I should close this topic? The problem I started off with has been solved which is LAN and WAN having an interference when a cable is connected to the WAN. Using the Network/Switch Luci web interface and separating them properly to their respective VLANs solves this issue.
The current problem is that when the Internet cable is connected to WAN. It is unable to access internet.

This behavior is definitely not normal. However, could it be connected anyhow that this router of yours is not exactly WE-826, but WR-830 as it is mentioned in the ubus call system board output?

The bootlog of 826 is also showing an eth1, which is missing from your bootlog.

Exactly something is off but guess what. I remembered that this is the second batch of device I am buying from this manufacturer. The first one worked very well. I had to go and get the first device, backup the configuration and then restore the backup on this one and everything worked like magic.

Still not sure what went wrong but I want to find out the disparity in both configurations.
Is it possible to inspect both configurations and find the difference? I still have about 45 of the bad devices that I will have to fix with the new config

You can diff the /etc/config/network and see the differences.

Working Config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd34:c31e:ee8e::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.4.4'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '90:50:5a:57:b7:70'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr '90:50:5a:57:b7:71'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto '3g'
	option device '/dev/ttyUSB2'
	option ipv6 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

Bad Config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd4a:226f:5b58::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.4.4'

config device 'lan_dev'
	option name 'eth0.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto '3g'
	option device '/dev/ttyUSB2'
	option ipv6 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

If your router model is officially supported, you should report this issue to the developers:

1 Like