WAN interface: Lost IP after few seconds instead of giving me WAN IP

Hello Guys,
I flashed my brand new d-link dir 869 with LEDE rom, turn my ISP modem/router (Sagemcom Fast 3284 DC) into the Bridge mode

To test the bridge mode, I plug directly my computer with DHCP option into the port 1 of the Fast 3284
During the boot sequence, I receive this IP 192.168.100.10. After a few more seconds the fully IP configuration changed to 77.***.***.*** . So I got a temporary IP for few seconds. I guess it takes time to register the new mac address of the device.

So, Internet connection is working. Ok, the Bridge mode is working fine. (I tried with 2 computers)

Now, I'll do the same with the dir-869. I plug the cable from port 1 (sagemcom) and to the WAN port of the DIR-869.
I'll reboot the modem, check on Luci interface, I can see the IP 192.168.100.10 on the WAN (eth0.2) interface.
But, few seconds later, instead of giving me a new IP address, the IP disapear.
If I check with ifconfig, the temporary IP is gone :frowning:
I'll reboot, try again, same...

Any idea ?

Thanks anyway :slight_smile:

Is there any relevant message in the logs?

@pywhy - you may need to restart your modem. Sometimes they will store the MAC address of the first connected equipment and only issue an IP address to that device. Restarting usually solves the issue. This is the case with many modems (mine works this way).

Alternatively, you could clone the MAC from the computer that did successfully get an IP from the modem.

1 Like

Hello Guys,
thanks for answering me :slight_smile: :slight_smile:

@eduperez
Speaking of log, you mean that logs ?
/tmp/log/lastlog
/tmp/log/wtmp
If yes, there is nothing, I might be wrong, right ?

@psherman
I rebooted a lot of time, no changes. Not a bad idea clone the mac from my laptop, I'll try that !

@pywhy - Two quick thoughts...

  1. Sometimes sequencing of power-up matters. I'd recommend powering down both devices for at least 10 seconds or so (modem and LEDE router). Then apply power to the modem, let it completely boot up and connect to the ISP. Once the boot process is complete, then turn-on/plug-in your LEDE router. Hopefully it will grab an IP this time.

  2. If you clone the MAC and that works, but the regular power-cycling/sequencing dosn't fix the problem, you might find that you need to specifically release the DHCP lease using either the laptop or the router (while using the cloned MAC) before the ISP will issue an IP to a new device. There is almost always a way to release a DHCP lease, but sometimes release/renew are combined, so you might need to use a command-line switch to release without renewing.

@psherman
Ok thanks for the insight, I'll try that (asap)
:slight_smile:

I tried to make a new test but before I updated my router with the last 17.01.2 build.
I only rebooted the ISP docsis modem after switching it to "Bridge" modem and the router (LEDE) manage to keep the temporary IP for about one minute and finaly switch it to the WAN IP ! :+1: :heart_eyes:

Anyway thanks for answers guys :slight_smile: