WAN interface custom DNS can't add a port number

When I want to choose not to use the DNS server advertised by the peer, I tried to customize the DNS to "" or "", but the invalid format was prompted.
Hope to get guidance, thanks!

1 Like


thank you. And I want to know if setting here will invalidate the ipset list :thinking:

It depends on the method by which you are using IP sets.

Thanks a lot. My shadowsocksr sets up the domain name forwarding list of dnsmasq. These domain names are added to ipset. And I use smartdns to run in dnsmasq upstream mode, the "no-resolv" option is enabled.

1 Like

Yep, that should work assuming that the clients do not use other ways to resolve domains, i.e. make sure the clients have disabled DoH/DoT, flush the client DNS cache, set up DNS hijacking if required.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.