WAN connection seems ok, but no connectivity from lan or device

My ISP changed fiber-modem into bridged mode after I asked for it. Now if I connect my pc-to the bridged port it works fine (same with the cisco-box on the other building). However my openwrt-box receives ip from isp:s dhcp, but I don't get any connectivity, not through LAN or using ping in the ssh-shell in the device itself.

I can't see problems in lan ip:s, but have used numerous different combinations anyway and the result has been the same.

Here is result from ifconfig:

br-lan Link encap:Ethernet HWaddr 4C:ED:FB:1A:8F:70
inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::4eed:fbff:fe1a:8f70/64 Scope:Link
inet6 addr: fd5d:c2ba:acd::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:434 errors:0 dropped:0 overruns:0 frame:0
TX packets:135 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:41759 (40.7 KiB) TX bytes:16294 (15.9 KiB)

eth0 Link encap:Ethernet HWaddr 4C:ED:FB:1A:8F:70
inet6 addr: fe80::4eed:fbff:fe1a:8f70/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:216450 errors:36 dropped:0 overruns:0 frame:0
TX packets:7604 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14053766 (13.4 MiB) TX bytes:751757 (734.1 KiB)
Interrupt:5

eth0.1 Link encap:Ethernet HWaddr 4C:ED:FB:1A:8F:71
inet addr:85.194.230.223 Bcast:85.194.231.255 Mask:255.255.248.0
inet6 addr: fe80::4eed:fbff:fe1a:8f71/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:215961 errors:0 dropped:0 overruns:0 frame:0
TX packets:6949 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10136228 (9.6 MiB) TX bytes:621296 (606.7 KiB)

eth0.2 Link encap:Ethernet HWaddr 4C:ED:FB:1A:8F:70
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:21193 (20.6 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:461 errors:0 dropped:0 overruns:0 frame:0
TX packets:461 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:34712 (33.8 KiB) TX bytes:34712 (33.8 KiB)

wlan0 Link encap:Ethernet HWaddr 4C:ED:FB:1A:8F:70
inet6 addr: fe80::4eed:fbff:fe1a:8f70/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14983 errors:0 dropped:0 overruns:0 frame:0
TX packets:11721 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1530341 (1.4 MiB) TX bytes:2503550 (2.3 MiB)

I can see your ISP is using VLAN 1 for the internet connection, is your WAN network configured on interface "eth0.1"? Could you post the contents of "/etc/config/network", please?

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5d:c2ba:0acd::/48'

config interface 'wan'
        option ifname 'eth0.1'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0.1'
        option macaddr '4c:ed:fb:1a:8f:71'

config interface 'wan6'
        option ifname 'eth0.1'
        option proto 'dhcpv6'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.2'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config device 'lan_dev'
        option name 'eth0.2'
        option macaddr '4c:ed:fb:1a:8f:70'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 2 3 4 6t'

Everything looks right there... You should try to debug the issue and see what is happening exactly. Is the gateway configured properly? Is it a DNS issue? ...?

can you post the output of

route  -n

do you ping an ip address or an domain?
try to ping 8.8.8.8