WAN connected to IPv6 but not IPv4

Hi all,

I'm new to openwrt, just flashed it two days ago.

After playing in luci for a long time, I have wireless lan, pppoe WAN/internet connection.

But now I realise I do not have an ipv4 on wan, so I can only connect to ipv6 enabled websites. How can I fix this?

Edit: from luci I can trace route and ping ipv4 websites, but from any client connected to my router, I have no ipv4 access.

Edit2: I figured out the solution. I had to select masquerading in the firewall settings for lan => wan. I don't actually know what this means. I just tried it after reading this thread: IPv6 works but IPv4 doesn't - #3 by gregdan3

Edit3: With the tl-wr902ac_v3 device, if I activate both radios my WAN drops within a few minutes. So it's not possible to run both and connect to WAN. Just thought I'd leave a note of that here. Everything is working now besides that.

I'll leave my config here in case it's useful, someone asked on my last thread:

board.json

{
	"model": {
		"id": "tplink,tl-wr902ac-v3",
		"name": "TP-Link TL-WR902AC v3"
	},
	"led": {
		"wlan2g": {
			"name": "wlan2g",
			"sysfs": "green:wlan",
			"trigger": "phy0tpt"
		},
		"lan": {
			"name": "lan",
			"sysfs": "green:lan",
			"trigger": "switch0",
			"type": "switch",
			"mode": "",
			"port_mask": "0x10",
			"speed_mask": ""
		},
		"wan": {
			"name": "wan",
			"sysfs": "green:wan",
			"trigger": "switch0",
			"type": "switch",
			"mode": "",
			"port_mask": "0x10",
			"speed_mask": ""
		}
	},
	"switch": {
		"switch0": {
			"enable": true,
			"reset": true,
			"ports": [
				{
					"num": 4,
					"role": "lan"
				},
				{
					"num": 6,
					"device": "eth0",
					"need_tag": false,
					"want_untag": false
				}
			],
			"roles": [
				{
					"role": "lan",
					"ports": "4 6t",
					"device": "eth0.1"
				}
			]
		}
	},
	"network": {
		"lan": {
			"device": "eth0.1",
			"protocol": "static"
		}
	}
}

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxx'

config device
	option name 'br-lan'
	option type 'bridge'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t'

config switch_vlan
	option device 'switch0'
	option ports '6t 4t'
	option vlan '2'

config device
	option name 'eth0.2'
	option type '8021q'
	option ifname 'eth0'
	option vid '2'

config interface 'wan'
	option proto 'pppoe'
	option device 'eth0.2'
	option username xxxxxx
	option password xxxxxx
	option ipv6 'auto'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '8.8.8.8'

lia,

Welcome to the forum and good that all is working

This sounds like a power issue.
Is your power adapter strong enough for the tl-wr902ac_v3 (at least 1,5A / 5 Volt)?

and even 2A / 5V written here:

DG.

Hi DGdodo,

Thanks for the welcome.

I thought it could be a power issue as well. The power adapter I am using is 5.1V 2.5A, but that may only be enough for the stock firmware, which I believe only allows for the operation of one radio, but I could be wrong.