WAN_6 preventing WAN6 working and ipv6 has a 50/50 chance of working

Model TP-LINK TD-W9980

Architecture xRX200 rev 1.2

Firmware Version OpenWrt SNAPSHOT r16135+4-dfee384a74 / LuCI Master git-21.077.59320-d1bf56d

Kernel Version 5.4.102

This is with the DSA mainline driver that's why I am a bit old on the kernel/version(cannot merge the patch into master for some reason, also on that note; perl does not compile when using the buildinfo on the 19.07 from the firmware downloads as .config with make defconfig so I build it using a custom .config without luci and it seems to work, after that I need to get it some internet and I download luci from opkg), however that WAN_6 interface gets added whenever I change dns servers on WAN interface, however when both interfaces (WAN6 and WAN_6) are online there is a 50/50 chance of me getting ipv6 networking and that only happens when WAN_6 is the first one to get a connection. The only way to remove the virtual dynamic interface WAN_6 is to do ifdown wan_6. Do you know if there is a more permanent solution? This is starting to get annoying.

You should be using only one of them, not both.
If wan has option ipv6 1 or manual, then the wan_6 is not created automatically and you need to create wan6 and configure it yourself.
Otherwise with option ipv6 auto, wan_6 is created automatically using the most generic settings and you should delete the wan6 interface.
In case you keep the wan_6 interface, don't forget to add it in the wan firewall zone.

1 Like

The wan_6 interface has no configuration options and is not needed for ipv6 at all. wan is configured as such

config interface 'wan'
        option ifname 'dsl0.835'
        option proto 'pppoe'
        option username 'inducerandomnessrealppoeusername100%@otenet.gr'
        option password 'passwork1234'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        list dns '8.8.8.8'
        list dns '8.4.4.8'
        option peerdns '0'

  • Is it configured for interface @wan - it doesn't seem to be properly setup.
  • If it's causing an issue, why don't you delete it?
  • Why did you make a custom config with a broken interface pre-configured or something?
    • (Wouldn't you re-do and re-make it properly...maybe I missed something??? :man_shrugging: )
1 Like

If you may not have noticed I mentioned that the WAN_6 interface cannot be deleted wither in uci or luci. It is not listed in /etc/config/networks either so if you have an idea throw it at me.

by default in openwrt wan6 is an dhcpv6 alias of wan what do you mean?

Well, this config only has the pppoe passwords, wan taking internet from dsl.835 for vdsl vlan and custom dns servers, I did not add no interface and changed nothing more than that.

You said you made a config file...you don't have the power to edit that???

My suggestion is to fix your config before making the firmware...

but again, perhaps I missed something (or you'll say I didn't notice...)

If you fix it first (assuming you test with fresh-official firmware that doesn't have the issue), I don't see how the problem could arise afterwards. If it does, let us know.

1 Like

Yeah, I did kind of, I needed to set dsl.835 so that was what the custom config was pointing at.

I tried official this morning, I changed PPPOE username and password, put in dsl.bin, set the binary to dsl.bin, changed the wan connection to dsl.835 and then it synced and worked perfectly. This is on 19.07.7, then I put in custom dns servers, then the ghost Wan_6 interface showed up again. I removed the dns servers and put them to default and it remained there. I shouldn't forget to mention this is not setting custom dns servers to the wan6 interface but the WAN interface only. I tried the same on commit 46c0634 which is the latest commit on the master branch and experienced the same behavior. I am currently running the latest commit with this /etc/config/network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd14:7f92:638f::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option ds_snr_offset '0'
	option firmware '/root/dsl.bin'

config interface 'lan'
	option type 'bridge'
	option ifname 'lan1 lan2 lan3 lan4'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'dsl0.835'
	option proto 'pppoe'
	option username 'user'
	option password 'password'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '18:a6:f7:32:0c:8b'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'


If not set, the default is auto.
uci set network.wan.ipv6='1' ; uci commit network; ifup wan

2 Likes

Ok this seems to be the solution but there is one problem.

Sun Mar 28 03:30:52 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:30:52 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:33:49 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:33:49 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:33:49 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:33:49 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:37:07 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:37:07 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:37:07 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:37:07 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available
Sun Mar 28 03:40:18 2021 daemon.warn dnsmasq[10834]: failed to create listening socket for fe80::aa0c:dff:fe28:7204%pppoe-wan: Address not available

I now get dnsmasq errors. Do you know what could be causing this?

I'm getting the same error on my rpi4b too, had any luck fixing it?

daemon.warn dnsmasq[3656]: failed to create listening socket for fe80::213:e3ff:fe57:b101%pppoe-WAN: Address not available

Nope, still happens no idea why.

PPP and dnsmasq issue

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.