Wake on lan problems

Hi,
I'm trying to send wake on lan packets to my server across an ethernet powerline network.
On the receiving end the ethernet port is bound to a bridge br0,from port eth1. The network ports are onboard the motherboard. I've installed etherwake on the openwrt router, and I've changed the port to br-lan and the mac address to that of the server which I've checked from the router using arp and confirmed on the server. I'm running this on the server to test for the receipt of a packet;
ngrep '\xff{6}(.{6})\1{15}' -d br0 -x port 9

The network card seems to support WOL,

 ethtool eth1 | grep Wake-on
        Supports Wake-on: pumbg
        Wake-on: g

but when I use etherwake I get this error

etherwake hawaiian
ether-wake: The Magic Packet host address must be specified as
  - a station address, 00:11:22:33:44:55

My etherwake config file is this;

 cat /etc/config/etherwake
config 'etherwake' 'setup'
        # possible program paths
        option 'pathes' '/usr/bin/etherwake /usr/bin/ether-wake'
        # use sudo, defaults to off
        option 'sudo' 'off'
        # interface, defaults to 'eth0'
        # -i <ifname>
        option 'interface' 'br-lan'
        # send wake-up packet to the broadcast address, defaults to off
        # -b
        option 'broadcast' 'off'

config 'target'
        # name for the target
        option 'name' 'hawaiian'
        # mac address to wake up
        option 'mac' '00:1d:7d:0d:2a:9d'
        # password in hex without any delimiters
        option 'password' 'AABBCCDDEEFF'
        # wake up on system start, defaults to off
        #option 'wakeonboot' 'off'

Trying this doesn't help either;

etherwake -D -i br-lan 00:1d:7d:0d:2a:9d
The target station address is 00:1D:7D:0D:2A:9D.
Packet is  00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 08 42 ff ff ff ff ff ff 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d 00 1d 7d 0d 2a 9d.
Sendto worked ! 116.

with nothing being detected by ngrep. I'm pretty sure my BIOS settings are correct too.

Does this all look about right?

Try with -b option:

etherwake -D -i "br-lan" -b 00:1d:7d:0d:2a:9d