VTU member violation error after moving to DSA network config

I am trying to migrate a custom built switch from OpenWrt 19.07, linux kernel 4.14, to OpenWrt 21.02, kernel 5.4. I have updated the network config file to use DSA configuration but am getting an error continuously printed out on the console.
The error is:

[ 1070.085131] mv88e6085 0000:01:00.0-1538:00: VTU member violation for vid 1717, source port 2

The switch is a Marvell 88e6176, with the following connections:

Port	Ethernet	Connected to
0	    eth1	External device
1	    eth2	Modem
2	    eth3	Maintenance port
3	    eth4	Wifi hub
4	    eth5	Wifi hub
5	    eth0	Processor

The original 19.07 network configuration file is:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface   'Lan'
	option type    'bridge'
	option proto   'static'
	option auto    '1'
	option stp     '0'
	option ipaddr  '192.168.76.2'
	option netmask '255.255.255.0'
	option ifname  'eth1 eth1.1 eth2.1 eth3 eth3.1 eth4 eth5'
	option description 'OAM LAN'
	option port1    '1'
	option port2    '1'

config ports
	option eth1s '1000'
	option eth1d 'full'
	option eth1a 'on'
	option eth2s '1000'
	option eth2d 'full'
	option eth2a 'on'
	option eth3s '1000'
	option eth3d 'full'
	option eth3a 'on'
	option eth4s '1000'
	option eth4d 'full'
	option eth4a 'on'
	option eth5s '1000'
	option eth5d 'full'
	option eth5a 'on'

config interface   'v1716'
    option type    'bridge'
    option proto   'static'
    option stp     '0'
    option auto    '1'
    option ipaddr  '10.72.9.194'
    option netmask '255.255.255.192'
    option ifname  'eth2.1716 eth4.1716 eth5.1716'
    option description 'VLAN 1716'

config interface   'v1717'
    option type    'bridge'
    option proto   'static'
    option stp     '0'
    option auto    '1'
    option ipaddr  '10.73.9.194'
    option netmask '255.255.255.192'
    option ifname  'eth2.1717 eth4.1717 eth5.1717'
    option description 'VLAN 1717'

config route
    option interface 'v1717'
    option gateway   '10.73.9.193'
    option target    '0.0.0.0'
    option netmask   '0.0.0.0'

And my latest attempt at the new DSA style network configuration:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
    option type 'bridge'
    option name 'br-Lan'
    list ports  'eth1'
    list ports  'eth2'
    list ports  'eth3'
    list ports  'eth4'
    list ports  'eth5'

config interface 'lan'
    option proto 'static'
    option device 'br-Lan'
    option ipaddr '192.168.76.2'
    option netmask '255.255.255.0'

config bridge-vlan
    option device 'br-Lan'
    option vlan   '1'
    list ports    'eth2:t'
    list ports    'eth1'
    list ports    'eth3'

config interface   "vLan"
    option conf_name 'vLan'
    option device  'br-Lan.1'
    option proto   'static'
    option stp     '0'
    option ipaddr  '192.168.76.2'
    option netmask '255.255.255.0'
    option description 'OAM VLAN'

config bridge-vlan
    option device 'br-Lan'
    option vlan   '1716'
    list ports    'eth2:t'
    list ports    'eth4:t'
    list ports    'eth5:t'

config interface   "v1716"
    option conf_name 'v1716'
    option device  'br-Lan.1716'
    option proto   'static'
    option stp     '0'
    option ipaddr  '10.72.1.129'
    option netmask '255.255.255.192'
    option description 'VLAN 1716'

config bridge-vlan
    option device 'br-Lan'
    option vlan   '1717'
    list ports    'eth2:t'
    list ports    'eth4:t'
    list ports    'eth5:t'

config interface   "v1717"
    option conf_name 'v1717'
    option device  'br-Lan.1717'
    option proto   'static'
    option stp     '0'
    option ipaddr  '10.73.1.129'
    option netmask '255.255.255.192'
    option description 'VLAN 1717'

config route
    option interface 'v1717'
    option gateway   '10.73.1.129'
    option target    '0.0.0.0'
    option netmask   '0.0.0.0'

config ports
	option eth1s '1000'
	option eth1d 'full'
	option eth1a 'on'
	option eth2s '1000'
	option eth2d 'full'
	option eth2a 'on'
	option eth3s '1000'
	option eth3d 'full'
	option eth3a 'on'
	option eth4s '1000'
	option eth4d 'full'
	option eth4a 'on'
	option eth5s '1000'
	option eth5d 'full'
	option eth5a 'on'

VLAN1 is working and I can ping from any port to any other port in the vlan, but I get continuous VTU member violations when anything is connected to the maintenance port, eth3.

What am I missing in my network config? Any suggestions are appreciated.

Ron

I have had a look at logread VTU member violation for vid 1 source port1 which had the same error on his Marvell 88exxx switch, but that setup was simpler and the solution doesn't apply here.

Any suggestions or hints at what to look at next?

Thaks

I found a solution. I removed the 'lan' interface definition:

config interface 'lan'
    option proto 'static'
    option device 'br-Lan'
    option ipaddr '192.168.76.2'
    option netmask '255.255.255.0'

and added another bridge-vlan with all ports untagged:

config bridge-vlan
    option device 'br-Lan'
    option vlan   '2'
    list ports    'eth1:u'
    list ports    'eth3:u'
    list ports    'eth4:u'
    list ports    'eth5:u'

config interface   "lan"
    option conf_name 'lan'
    option device  'br-Lan.2'
	option proto   'static'
	option stp     '0'
	option ipaddr  '192.168.76.2'
	option netmask '255.255.255.0'
	option description 'OAM VLAN'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.