VPN: Temporarily solve same subnet conflicts

I am using my Gl.Inet router while I am traveling and I connect to my home with VPN. Sometimes I have problem, when remote subnet is the same as my home subnet (192.168.1.x). Sure, I should change this to something not commonly used range, but I have many devices on my network and I don’t have time to change now.

On my Mac I am using this temporary solution:

sudo route add -host -interface ppp0

If I want to access home device at, it would be accessing trough ppp0 VPN interface. It works.

It is possible to set static route like this on Glinet router? I set static route like this, but it's not working:

It seems is the unit's own IP address. But the gateway should never be its own address. (Unless maybe you want to add an unreachable route.) And the route specifies "lan" but don't you want to use wg0? Which interface is wg0 assigned to? I guess it isn't "lan". is the WG0 IP (VPN interface) address. It is connecting to the remote server I tried with IP 9.1 too, but it's not working either.

I have these options:

I can't see wg0 option here, neither in Interfaces:

...but I see it if I list interfaces with ifconfig:

Manually specifying ip route trough cli works:

ip route add dev wg0

Any way to achieve this by GUI?

Yes. You add it in Network > Static Routes.

1 Like

If you see previous posts, it's not working from there. Probably I am missing something.

If you have your own VPN server, you can provide both IPv4 an IPv6 to avoid routing conflicts.