VPN policy does not work

Hello, I am a very newbie in IT and hoping someone can help. I managed to install openwrt on my Pi4 and everything runs ok except VPN. I have several VPN instances configured and the very first I added works well. Then I created VPN policies so that certain IPs get connected to VPN. Now if I switch to any other VPN instance (stop first star another) it also connects to VP but my all network computers get connected to the other VPN instance location regardless of a VPN policy. Switched back to the first VPN instance and everything gets to normal. What I am missing here?...Thank you.

Does the VPN policy switch change something in the network ?
or does everything remain the same, from a client point of view ?
like default GW, DNS, etc ....

Thank you for your reply. I wish I could understand better your question...As I understand everything remains the same, local IPs in the policy are static. Same policy when it is switched to another openVPN instance (same VPN provider but different country). So nothing is changed just stop one instance and start another but the result is different.....Although in the VPN configuration file (.ovpn that i took this configuration from) I see different dhcp-option DNS mentioned. In one (the one is working fine) I see some IP put there in another configuration I see dhcp-option DNS dhcp-option DNS mentioned. Hope it helps.

For the fun of it, do a traceroute from your client to, with the working, then the non-working VPN.

Yes, I tried on the machine that is not in the policy and traceroute is completely different in both situations. The second run on the non working VPN showed pretty much the same as it showed on the other computer which is on the policy.

Then I tried on the machine that is in the policy and it is kind of similar in both cases just different IPs and few other things.