VPN connection issue

I have been provided a openvpn (ovpn) file to connect to a VPN. Getting issues where I had to manually add a route to make it work. sudo ip route add xx.xx.x.xxx dev tun0 .
The thing is nobody else appears to have issues with their ovpn file.

My company VPN supplied us with an ovpn file to connect to their VPN. I had issues connecting on both windows and linux. These were resolve resolved with this command sudo ip route add xx.xx.x.xxx dev tun0 . Although I recently started having issues on particular subdomains. Perhaps they have moved to some other route..

The thing is nobody else, including the guy who started with me had any issues. Could this be a router issue ?

Having this problem with both windows and ubuntu. Could this be a openwrt issue ?
I have changed routers and this issue has persisted. Using 19.0.5 on tp-link C7 1750

My local subnet is 192.xx , IP assigned by vpn is 10.xx
Thanks!
Edit: I reverted to old router mi mini with openwrt 19.0.x and the the recent issue vanished! I am not sure what settings differ. But I haven't touched any firewall/vpn settings in the new one.

This depends on your routing config as well as the VPN server and client configs.
Post the output from the Linux workstation before and after establishing the VPN connection:

ip address show; ip route show table all; ip rule show
1 Like

Is the OpenVPN client running on the router or the PC?

1 Like

PC only. No VPN settings were touched on router

Could be related : can't forward ports
Added section to /etc/network/firewall to forward luci web for testing only.

config redirect
        option src 'wan'
        option name '80'
        option src_dport '80'
        option target 'DNAT'
        option dest_ip '192.168.1.1'
        option dest 'lan'

In that case, unless you configured the router in some specific manner, this issue does not seem to be related to the router configuration at all.

2 Likes

You do not have to forward a port to the router itself, you just have to open it. However, opening port 80 directly to the internet is a security risc.

1 Like

oh! thank the galaxies! I figured it out. Manual Routes still required

In openwrt settings > Network->DHCP and DNS->General Settings-> Untick "Rebind protection"


I did not explain my problem well..

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.