VPN Bypass (split tunneling) Service + Luci UI

Based on the counters (682K/743M) it looks like it's routing some traffic.

1 Like

I’ve started VPNBYPASS and certain streaming apps on the Apple TV are working without bother. I have checked, and Speedtest states I am connected to my ISP. Netflix and Amazon Prime are giving network error messages. Could this be something else I need to add to the settings for VPNBYPASS then?

Thanks for keeping me right.

Probably your router's DNS is still going out via VPN alerting Netflix and Prime. As I have no idea neither what else might be going on on your network nor how do Netflix or Amazon detect VPN use, I'm not sure if I can be of any more help otherwise.

You may want to disable default routing via VPN completely and use a vpn-policy-routing package to configre traffic you want to go out via VPN instead.

Thanks Stan, yes, totally frustrated by Prime and Netflix on this. Thanks for all your help, I will look at policy routing and see if that works any better. :+1:t2:

There are many vpn providers that give you a split tunneling feature in their apps such as ExpressVPN, NordVPN, PureVPN and more.

Sure, if you want to limit your VPN connection to a single Windows PC you can have split tunnelling while using some VPN providers' proprietary applications. For everything else -- there're vpnbypass and vpn-policy-routing packages (when you're running your VPN Client on a router).


I use Policy Routing to fix the issue /

Can anyone confirm that bypassing domains is working with OpenWrt 21.02.0-rc3?
I have issues with this after upgrading from 19.07.7

Oh, sorry, I fixed it in vpn-policy-routing, but not in vpnbypass -- can you try the updated IPK from my repository and confirm it works before I submit the pull request for the main OpenWrt repo?

The IPK is available here: https://github.com/stangri/repo.openwrt.melmac.net/blob/master/vpnbypass_1.3.2-1_all.ipk?raw=true

1 Like

Hi, thank you very much for the feedback. I will try it tomorrow and let you know.

@stangri I installed the latest version but the issue remains

Which version of dnsmasq do you have installed? Also, can you please confirm which device have you tested this most recent package with OpenWrt 21.02.0-rc3?


dnsmasq-full 2.85-1
The router is a Netgear R7800

It should be working fine then. Can you post/PM me your vpnbypass, network and firewall configs? Is it just the domains bypass which is not working or bypassing in general? How did you test it?

I'll try to reproduce the issue when I have the information above.

1 Like

It works fine with IPs. I check with whatsmyip.org and also there are specific sites in my country that I cannot access through VPN. I PM you my config. Only domain specific bypass seems to not working.

Edit: Upgraded to dnsmasq-full 2.85-2 but still no luck

Thank you for helping troubleshoot and testing the bugfix!

You are welcome. Thank you too.

Hi @stangri i got probem when start the VPN Bypass, it couldn't started. And sometimes when i open the VPN Bypass page it took long time to open and when opened it blank show nothing.

OpenWrt version? Router model? Description of VPN(s) you use? System logs?

I'm using openwrt 19.07 and my device is ZTE ZXV10 B860H.
For VPN i'm using LIBERBET this from local developer but treated as tun same like openvpn.
At the first time i added this remote ip to bypass (whatismyipaddress.com) and it's work fine, but after i add more ip to bypass then it stop working.
Here is the log.