Vodafone config D7800

Sorry for the confusion. It's the D7800

Not sure if that is copypaste error, but you have a space in ifname...
Option if name 'eth1'

confog ?

One strange thing is the starting capital letters in "Config", "Option" etc. (they should be just config, option etc.

You should copy-paste the config directly...

I was writing it out on my phone as I didn't have a connection. Here we go

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdd7:7fbd:fedd::/48'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option proto 'pppoe'
option username 'xxxx@broadband.vodafone.co.uk'
option password 'xxxxxz'
option ipv6 '0'
option mtu '1492'
option device 'eth0.101'

config interface 'wan6'
option proto 'pppoe'
option username 'xxxxx@broadband.vodafone.co.uk'
option password 'xxxxxx'
option ipv6 '0'
option device 'eth0.101'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 0t'

config device
option type '8021q'
option ifname 'eth2'
option vid '1'
option name 'eth2.1'
option mtu '1492'
option ipv6 '0'

config device
option name 'eth1.1'
option type '8021q'
option ifname 'eth1'
option vid '1'

config device
option name 'eth1'
option mtu '1492'
option ipv6 '0'

config device
option name 'eth0'
option ipv6 '0'
option mtu '1492'

config device
option name 'wlan0'

config device
option name 'eth0.2'

Is this what was needed?

How is the D7800 connected to the broadband service?
Are you trying to use the DSL port, or ethernet WAN port?

I didn't think there is any support for DSL port on this device, but I could be wrong.

In any case, eth0.101 is incorrect regardless of whatever connection method, VDSL, ethernet etc for Vodafone UK.

If you are using ethernet WAN port wired to an external Openreach VDSL/Gfast modem, or FTTP ONT, I think you need to change it back to factory default value for the D7800. eg. is it eth0.2 ?

If you have Vodafone on CityFibre, I think it may use the same interface settings, but don't quote me.

Your posted config looks a bit of a mess to me?

fwiw, I would suggest you reset the D7800 and return the openwrt settings to factory defaults, and start over. If the DSL port is not supported, I would hope the default ethernet wan port (eth0.2 ??) is enabled by default ready to use, if you were to plug it into spare LAN port of your Vodafone router to test?

Then simply just change the protocol to PPPoE and add username and password, and plug it into the modem or ONT.

I'm not familiar with the D7800, so can I suggest you post the contents of the 'default' /etc/config/network before you make any changes if you still have problems?

Vodafone UK don't yet support IPv6 at this time according to ISPreview.co.uk

Thanks is that a lack of DSL support on the device or on openwrt on the device? It worked fine on stock for example.

Are you trying to use the DSL? You didn't yet answer that.

Looks like the OpenWrt wiki pretty clearly says that the DSL part is not supported by OpenWrt...

https://openwrt.org/toh/netgear/d7800

Important: The DSL modem within the D7800 is NOT supported by OpenWrt.

The DSL port will NOT work if you install OpenWrt onto the D7800.

OpenWrt does apparently work for the rest of the D7800 hardware, so it can be used as a regular router (without modem).

I added the following to the wiki page last night:

Important: The DSL modem within the D7800 is NOT supported by OpenWrt.

after searching the forum to confirm my suspicions there is absolutely no support for the little known Lantiq VRX320 modem chip.
Netgear Nighthawk D7800 vs R7800

If for example you wish to use a D7800 with OpenWrt as the primary router wired to a VDSL/FTTC line, you will need to install a 5-10 years old Openreach (Huawei or ECI) VDSL modem or similar device.

Thanks all - I have taken a network cable from my Vodafone modem now that I know the DSL doesnt work. I can use this fine as a router with OpenWRT now. That said, having some issues with the WiFi speeds and connecting dropping and and out every few seconds

64 bytes from 8.8.8.8: icmp_seq=1449 ttl=117 time=20.236 ms

64 bytes from 8.8.8.8: icmp_seq=1450 ttl=117 time=21.991 ms

64 bytes from 8.8.8.8: icmp_seq=1451 ttl=117 time=23.271 ms

64 bytes from 8.8.8.8: icmp_seq=1452 ttl=117 time=18.594 ms

64 bytes from 8.8.8.8: icmp_seq=1453 ttl=117 time=42.268 ms

64 bytes from 8.8.8.8: icmp_seq=1454 ttl=117 time=21.371 ms

64 bytes from 8.8.8.8: icmp_seq=1455 ttl=117 time=16.789 ms

64 bytes from 8.8.8.8: icmp_seq=1456 ttl=117 time=22.714 ms

64 bytes from 8.8.8.8: icmp_seq=1457 ttl=117 time=21.493 ms

64 bytes from 8.8.8.8: icmp_seq=1458 ttl=117 time=59.002 ms

64 bytes from 8.8.8.8: icmp_seq=1459 ttl=117 time=96.032 ms

64 bytes from 8.8.8.8: icmp_seq=1460 ttl=117 time=29.569 ms

64 bytes from 8.8.8.8: icmp_seq=1462 ttl=117 time=36.329 ms

64 bytes from 8.8.8.8: icmp_seq=1463 ttl=117 time=21.992 ms

64 bytes from 8.8.8.8: icmp_seq=1464 ttl=117 time=75.239 ms

Request timeout for icmp_seq 1465

Request timeout for icmp_seq 1466

Request timeout for icmp_seq 1467

Request timeout for icmp_seq 1468

Request timeout for icmp_seq 1469

Request timeout for icmp_seq 1470

Request timeout for icmp_seq 1471

Request timeout for icmp_seq 1472

Request timeout for icmp_seq 1473

Request timeout for icmp_seq 1474

Request timeout for icmp_seq 1475

Request timeout for icmp_seq 1476

Request timeout for icmp_seq 1477

Request timeout for icmp_seq 1478

Request timeout for icmp_seq 1479

64 bytes from 8.8.8.8: icmp_seq=1480 ttl=117 time=419.770 ms

Request timeout for icmp_seq 1481

64 bytes from 8.8.8.8: icmp_seq=1482 ttl=117 time=98.860 ms

64 bytes from 8.8.8.8: icmp_seq=1483 ttl=117 time=21.758 ms

64 bytes from 8.8.8.8: icmp_seq=1484 ttl=117 time=16.479 ms

64 bytes from 8.8.8.8: icmp_seq=1485 ttl=117 time=17.153 ms

64 bytes from 8.8.8.8: icmp_seq=1486 ttl=117 time=19.160 ms

64 bytes from 8.8.8.8: icmp_seq=1487 ttl=117 time=18.254 ms

64 bytes from 8.8.8.8: icmp_seq=1488 ttl=117 time=19.317 ms

64 bytes from 8.8.8.8: icmp_seq=1489 ttl=117 time=33.426 ms

64 bytes from 8.8.8.8: icmp_seq=1490 ttl=117 time=76.713 ms

64 bytes from 8.8.8.8: icmp_seq=1491 ttl=117 time=121.291 ms

64 bytes from 8.8.8.8: icmp_seq=1492 ttl=117 time=172.339 ms

64 bytes from 8.8.8.8: icmp_seq=1493 ttl=117 time=219.327 ms

64 bytes from 8.8.8.8: icmp_seq=1494 ttl=117 time=16.818 ms

64 bytes from 8.8.8.8: icmp_seq=1495 ttl=117 time=17.715 ms

64 bytes from 8.8.8.8: icmp_seq=1496 ttl=117 time=17.296 ms

Request timeout for icmp_seq 1497

Request timeout for icmp_seq 1498

Request timeout for icmp_seq 1499

Request timeout for icmp_seq 1500

Request timeout for icmp_seq 1501

Request timeout for icmp_seq 1502

Request timeout for icmp_seq 1503

Request timeout for icmp_seq 1504

Request timeout for icmp_seq 1505

Request timeout for icmp_seq 1506

Request timeout for icmp_seq 1507

Request timeout for icmp_seq 1508

Request timeout for icmp_seq 1509

Request timeout for icmp_seq 1510

Request timeout for icmp_seq 1511

Request timeout for icmp_seq 1512

64 bytes from 8.8.8.8: icmp_seq=1513 ttl=117 time=89.518 ms

64 bytes from 8.8.8.8: icmp_seq=1514 ttl=117 time=128.569 ms

64 bytes from 8.8.8.8: icmp_seq=1515 ttl=117 time=177.228 ms

64 bytes from 8.8.8.8: icmp_seq=1516 ttl=117 time=220.734 ms

Request timeout for icmp_seq 1517

64 bytes from 8.8.8.8: icmp_seq=1518 ttl=117 time=17.747 ms

64 bytes from 8.8.8.8: icmp_seq=1519 ttl=117 time=20.038 ms

Request timeout for icmp_seq 1520

64 bytes from 8.8.8.8: icmp_seq=1521 ttl=117 time=17.343 ms

64 bytes from 8.8.8.8: icmp_seq=1522 ttl=117 time=17.041 ms

64 bytes from 8.8.8.8: icmp_seq=1523 ttl=117 time=17.506 ms

64 bytes from 8.8.8.8: icmp_seq=1524 ttl=117 time=18.806 ms

64 bytes from 8.8.8.8: icmp_seq=1525 ttl=117 time=17.679 ms

64 bytes from 8.8.8.8: icmp_seq=1526 ttl=117 time=30.306 ms

64 bytes from 8.8.8.8: icmp_seq=1527 ttl=117 time=79.974 ms

64 bytes from 8.8.8.8: icmp_seq=1528 ttl=117 time=103.576 ms

Request timeout for icmp_seq 1529

Request timeout for icmp_seq 1530

Request timeout for icmp_seq 1531

Request timeout for icmp_seq 1532

Request timeout for icmp_seq 1533

Request timeout for icmp_seq 1534

Request timeout for icmp_seq 1535

Request timeout for icmp_seq 1536

Request timeout for icmp_seq 1537

Request timeout for icmp_seq 1538

Request timeout for icmp_seq 1539

Request timeout for icmp_seq 1540

Request timeout for icmp_seq 1541

Request timeout for icmp_seq 1542

Request timeout for icmp_seq 1543

64 bytes from 8.8.8.8: icmp_seq=1544 ttl=117 time=454.406 ms

64 bytes from 8.8.8.8: icmp_seq=1545 ttl=117 time=16.603 ms

64 bytes from 8.8.8.8: icmp_seq=1546 ttl=117 time=33.723 ms

64 bytes from 8.8.8.8: icmp_seq=1547 ttl=117 time=16.444 ms

64 bytes from 8.8.8.8: icmp_seq=1548 ttl=117 time=17.626 ms

If the D7800 is in 'router' mode and is wired to the Vodafone VDSL modem-router (default 192.168.1.1?), change the LAN IP address of the D7800 to use a different subnet (eg. 192.168.111.1).

Vodafone routers do not support dedicated 'bridge-modem' (non-router) mode.

Unrelated to your wifi issue, if the D7800 is wired into a current model Vodafone UK VDSL modem-router, have you looked at configuring the D7800 as a 'dumb access point', instead of default 'router' mode, to avoid double NAT firewall issues caused by connecting one 'router' to another 'router'.
https://openwrt.org/docs/guide-user/network/wifi/dumbap

Hi Bill888 - thanks for that. I actually realised that was the issue last night. I changed it just to a static of 192.168.1.2 and the connection has been solid since then. I am still struggling with openVPN client over it (VPN is connecting but traffic is not passing) so will look at the NAT issue and see if that helps

Is the D7800 configured as a router or dumb access point and what port on D7800 is wired to the VF router?

Post the /etc/config/network.

I suspect if VF router has LAN IP 192.168.1.1 and if D7800 is in router mode with LAN IP 192.168.1.2, you are going to have problems later especially when configuring openvpn client. ie. LAN IP of D7800 needs to be changed to use different subnet. eg. 192.168.111.1, 192.168.2.1 etc .

As far as I'm aware, openvpn won't work on a dumb access point.

https://openwrt.org/docs/guide-user/services/vpn/openvpn/client-luci#alternative_guide_for_openvpn_client_using_luci

Take a look at the alternative guide at bottom of wiki page which shows double router config like your setup.

Following the dumb AP guide ive managed to lock myself out of the router. Can hit the IP but the luci interface or ssh now wont function. Think I will need to reboot and start again.

If you are going to run openvpn client on the D7800, you should use default router mode.....

Reset the D7800.
Change the LAN IP to 192.168.111.1 for example. Do NOT use 192.168.1.x address if VF router is on 192.168.1.x.
Connect WAN port from D7800 to LAN port VF router.
Check internet access is working.
Set up wifi.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdba:08c0:ac80::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.2' (I will change this now to a new subnet)
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option delegate '0'

config interface 'wan'
	option device 'eth0.2'
	option force_link '1'
	option proto 'dhcp'
	option peerdns '0'
	list dns '162.252.172.57'
	list dns '149.154.159.92'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'surfsharktun'
	option proto 'none'
	option device 'tun0'

I don't think this setting should be present.

Some progress - Got the VPN link working from the D7800 fully now. able to ping/tracert/nslookup from the Luci interface. When I connect a client though I don't get connectivity. Is this an issue with the firewall zones I have setup on the D7800?

ping: sendto: No route to host
Request timeout for icmp_seq 0
ping: sendto: No route to host

Post the /etc/config/firewall and revised /etc/config/network. Someone may be able to help as we don't know what instructions you used to set up the vpn.

Guides provided by VPN providers may be incomplete or out of date. I notice Surfshark's own guide still uses CLI !

I have my VPN up now. All running and can check connectivity with IPLeak or in system logs. However, when I run my phone and the VPN client over the Vodafone connection I get 40MBPS. When I run anything over the OpenWRT client connection I am getting 0.1-0.2Mbps....

Which VPN endpoint (location of server) are you using?
Try a server in the UK to see if there is an improvement in speed.

Get a free account from ProtonVPN and try speedtest with one of the free servers to see if speeds are any better.

https://openwrt.org/docs/guide-user/services/vpn/openvpn/performance