Vnstat missing traffic (maybe not vnstats mistake?)

Hello Guys,

I Setup vnstat on my second Router (Both Router using LEDE 17.01.0 Stable) on the same Router-Hardware like my first router.
The First router is connected to the WAN directly (using pppoe-wan Interface). The second one is connected on the first LEDE-Router using DHCP-Client (eth0).

Problem: On the first Router vnstat monitors its traffic just fine without any trouble: loading 20gigs and vnstat shows 20 gigs rx.
But on the second LEDE-Router which using dhcp-client and NOT pppoe, vnstat has missing traffic (same vnstat config as on first router).

On second router: If I am download 10 gigs file, vnstat shows only 200MB on rx.
I changed and tested everything in vnstat.conf (UpdateInterval, PollingRate etc) but nothing helped.

But can It be thats not vnstat mistake ? Today I tested the following on the second Router:
Restarted the router (to be sure traffic data is flushed in luci -> network -> interfaces).
Downloaded again 10 gig file, but now not only vnstat shows the wrong traffic (again 200 MB rx).
If I take a look on luci webinterface (under network interfaces), the LAN interface bridge shows it wrong also (200 MB too)...
So the mistake is not from vnstat ?

Any workaround to fix this ? :frowning:

Hardware: Both TP-Link Archer C7 v2

EDIT: has it to do with wrong VLAN setup maybe too ? on LEDE factory settings all ports are on VLAN ID 1 - untagged except WAN port and CPU (are the same on Archer c7): these two are on VLAN ID 2 untagged

now I have all ports and CPU / WAN, all on the same VLAN: VLAN ID 1 untagged

Did you find a solution to your issue? :slight_smile:

Sorry but no... :frowning:

But I cant test it anymore again coz my LEDE Router is connected to an external WAN Modem.

You can use collectd and rrd as an alternative. If you only want some traffic graphs:
RRDTool Howto on Openwrt

I tested it on another LEDE Router without problems or without wrong stats :slight_smile:

If you have installed luci-app-statistics you will get a new entry in your router webinterface to configure it. If you want to see your network traffic: You only need to activate network Plugin and change the WAN interface there :slight_smile: